Can't update to iPhoto 9.2

Discussion in 'MacBook Air' started by mwxiao, Oct 12, 2011.

  1. mwxiao macrumors regular

    Jul 5, 2007
    I am using the latest MBA. Current iPhoto is 9.1.5.

    I updated to 10.7.2 already. "Software update..." says my software is up to date. No iPhoto 9.2 was shown.

    I opened App Store and went to "Purchased list", iPhoto was shown as "update". But when I clicked on it, it popped up a window saying I'm the not account that bought iPhoto. What the f'k is going on???? I only have one Apple ID, how am I supposed to update????
  2. halledise macrumors 65816

    May 7, 2009
    Hamilton Island, Whitsundays, QLD Australia
    you'll find it here:
  3. Tbone999 macrumors member

    Jun 18, 2009
    That doesn't solve the problem. If you manually download 9.2 and try to install it to upgrade iPhoto, it says you can only do it from the App Store.
  4. Glennsune macrumors newbie

    Oct 3, 2008
    Got this exact same problem. Anyone found out how to solve it?
  5. krazzix macrumors member


    Jun 15, 2010
    Same issue here, however if i logout, and then try to update, it says i have to buy it first! :eek: I'm not gonna pay for a program that came with my mac...
  6. rk25123 macrumors regular

    Aug 17, 2010
    Hi there, that's kinda strange, because I too have the latest MacBook Air and for me (and should also for you since iLife came pre-installed) the update downloaded and installed flawlessly via App Store, in the updates section (not in the purchased one). Maybe it's just a bug, Mac App Store seems a Beta to me for how laggy and buggy it is. Usually when it says something about another account it's 'cause you have pirated software and the App Store receipt inside it is indeed connected to another account, making it impossible to download the update. If that's your case what you have to do is to right click on iPhoto and select "show package content", open the "Content" folder and delete the "_MASReceipt" folder inside it, now the update will show up on Software Update.

    Please feel free to point out any grammar disaster I made, it's always a good time to improve my english.
  7. krazzix macrumors member


    Jun 15, 2010
    Works! Thanks a lot :)
  8. herbs77 macrumors newbie

    Oct 16, 2011
    this worked for me too. Thankyou. Can now start using iCloud with iPhoto 9.2 :)
  9. chasteve macrumors newbie

    Nov 6, 2009
    iphoto 9.2

    Found this problem yesterday. Went to the Apple store and ask this question to one guy and he thinks that we can just upgrade it by checking update. It was not so.. I found a message online and they ask us to delete the iPhoto application and re-install ilife 11 (you have to have it, even it is an old version.)

    Came home, and delete iPhoto, iMovie and garageband and re-install the ilife 11 again. go thru check update and it updated all 3.. guess what.. I am still running an older version.

    Went back to internet and found this link.
    and install it and now, I am using iPhoto 9.2.

    Can we just go to this link and install 9.2? You can try it out.
  10. Glennsune macrumors newbie

    Oct 3, 2008
    Solved the problem for me. Thanks a lot!
  11. Villon macrumors newbie

    Sep 28, 2008
    I had the same issue and read on another forum that I was supposed to delete/deinstall iPhoto. So I did.

    When I search for iPhoto in App Store, it says "Accept" instead of "Buy" or "Install". When accepting, App Store tells me "These apps cannot be accepted on this computer. Future updates of these apps can be found through Software Update."

    Ah. So I check for updates, but seem to be fully updated. This link (the iPhoto page) only contains an upgrade and can only be used if some previous is installed. My OS X Lion of course didn't come with a disc of any kind.

    Would a Leopard disc do? Is there any way of solving this that wouldn't require me spending god knows how many hours of finding that disc?

    One odd thing is that the system is completely new as in no pirated apps of any kind. The only thing I can think of is Lion Tweaks that I just had to use to get rid of the hideous new iCal design.
  12. JoganJani macrumors member

    Oct 23, 2007
    Same thing happened with me. however, when I tried to save the image/photo from web site to my iPhoto it triggered the upgrade.
  13. jowie macrumors 6502a

    Jun 9, 2004
    London ish
    I'm having the same problem.

    My company recently upgraded my laptop to OS X Lion and was pre-installed with iPhoto purchased under a different Apple ID. I have my own purchased version so wanted to update the app, but it asked for the other user's password.

    So I decided to uninstall the app using Launchpad and try downloading it again. However, when I go to it in the Mac App Store, I get the "ACCEPT" button and then the same following message as you.

    I've contacted Apple email customer support, hopefully they should be able to help me...
  14. rheftmann macrumors newbie

    Jul 10, 2009
    Trashing Receipt also works iPhoto 9.1 to 9.3

    Great suggestion that, opening Package in iPhoto app and trashing the Receipt file from the MASReceipt folder. Thanks, rk25123!

Share This Page