Can't Update why?

Discussion in 'macOS' started by krewelement394, Nov 3, 2009.

  1. krewelement394 macrumors regular

    krewelement394

    Joined:
    Feb 14, 2008
    #1
    hi i am having a problem updating my applications on my macbook, it is running on Mac os Snow Leopard. everytime i get a message saying that there is a new update for itunes, imovie, iphoto etc. i click on update and it begans to download but after a while i get a message saying this :

    The update could not be expanded and verified. It may have been corrupted or tampered with during downloading. The update will be downloaded and checked again the next time that Software Update runs

    why am i getting this and how can i stop it?
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    Don't know why. Not sure if this will stop it, but it can't hurt...

    Replace the com.apple.SoftwareUpdate.plist file.
    It's in your Home folder > Library > Preferences
    Drag it to the desktop
    Try a download

    Did that help?
     
  3. krewelement394 thread starter macrumors regular

    krewelement394

    Joined:
    Feb 14, 2008
    #3
    it did not work it gave me the same message
     
  4. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #4
    Delete the
    Code:
     ~/Library/Caches/com.apple.Software
    folder.
     
  5. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #5
    After posting that, I discovered there is another plist file for SU in the
    Library > Preferences folder found in your top-level hard drive folder.

    Try the same procedure with that one. Don't Trash the file until you're
    sure it's safe to do so.
     
  6. krewelement394 thread starter macrumors regular

    krewelement394

    Joined:
    Feb 14, 2008
    #6
    could not find that folder and i searched for another SU document using spotlight but no good i just find one...:( my iPhoto and everything else that needs updating cant update because i still get this


    "The update could not be expanded and verified. It may have been corrupted or tampered with during downloading. The update will be downloaded and checked again the next time that Software Update runs."
     
  7. webgoat macrumors 6502a

    webgoat

    Joined:
    Sep 20, 2007
    Location:
    Austin, TX
    #7
    delete everything in /Library/Updates and try again
     
  8. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #8
    Strange. But, I'm still on Leopard. It's too early for snow!!
    This is where mine is:
    click on hard drive icon on the Desktop
    open Library
    there's Preferences w/ SU plist file inside
     
  9. sailboatvn macrumors newbie

    Joined:
    May 20, 2010
    #9
    I'm having exactly the same issue. Not sure which caused this and any solution for this. You can follow my question posted on Apple forum

    http://discussions.apple.com/thread.jspa?threadID=2428616&tstart=0
     
  10. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #10
    I didn't follow your link.

    Did you try the plists mentioned above? ...or the Terminal command?

    I see that the OP never came back to enlighten us.
     
  11. jewomatic9000 macrumors newbie

    Joined:
    Jul 8, 2012
    #11
    Same Problem

    having the same problem, running 10.6.8. Please help!

    Has anyone's iPhone stopped updating since this problem arose? iTunes no longer sees my iPhone when I plug it in.
     
  12. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #12
    I don't understand why people keep posting to this thread without saying that they've tried the proposed solutions and what happened when they did. Read all the posts, try the ideas offered, and report back!
     

Share This Page