cant upgrade cydia!

Discussion in 'Jailbreaks and iOS Hacks' started by ipodtouchftw, Jun 24, 2009.

  1. ipodtouchftw macrumors member

    Joined:
    Jun 16, 2008
    #1
    i just jailbroke and unlocked my 2g iphone on vista and when i try to do the essential upgrade when i open cydia for the first time it gives an error. how do i fix this?
     
  2. lllsup3rd4nlll macrumors newbie

    Joined:
    Jun 16, 2009
    #2
    i had a similar issue with my 3G using redsn0w on windows XP. i ended up restoring back to factory 3.0, then re-jailbreaking it with redsn0w on my mac and it's working fine. i really don't know what the problem was, but i think it could have something to do with a bad (yet still functioning) version of either the 3.0 firmware (if you downloaded it from somewhere other than itunes) or your jailbreaking program. either that or it was just a bug with cydia. whatever the case, i suggest restoring back to factory 3.0 and trying to maybe find a diff copy of the software/firmware, they giving it another shot. good luck!
     
  3. ReleasedAce macrumors newbie

    ReleasedAce

    Joined:
    Apr 15, 2009
    #3
    When you jailbroke did you install cydia and icy? Thar was my problem so I restored re jailbroke without icy now cydia works flawless.
     
  4. JohnFa macrumors regular

    Joined:
    Jun 12, 2009
    #4
    Same here. I re-jailbroke with only cydia and it worked fine. Then added the ripdev repo and installed icy from Cydia. Works perfectly now.
     
  5. ipodtouchftw thread starter macrumors member

    Joined:
    Jun 16, 2008
    #5
    It works! thanks
     
  6. DinoMachino macrumors member

    DinoMachino

    Joined:
    Jun 24, 2009
    Location:
    macphis
    #6
    thanks a lot!

    i was freaked out that i messed up my phone til i finally found this little thread. thanks!
     

Share This Page