can't upgrade to 10.7.2

Discussion in 'Mac OS X Lion (10.7)' started by tulanejosh, Oct 12, 2011.

  1. tulanejosh macrumors member

    Joined:
    Sep 12, 2009
    #1
    Have been trying for hours and hours now... it downloads just fine - snappy quick. but when i go to install it - it just won't do it. if i do it through software update i get an error that says it "couldn't expand and was corrupted during download". Have retried probably going on 10x now with no luck.

    Also downloaded the files directly from Apple - at first got checksum errors, then i turned of disk image verification. It started the install process but immediately gave me an unknown error and said to contact the software manufacturer.

    I'm not running a developer build or anything, i don't have file vault turned on and have never experienced any issues like this before.

    any thoughts on this one?
     
  2. lighthouse_man macrumors 6502a

    Joined:
    Mar 13, 2005
    #2
    My only suggestion to create another administrator account and try to update from there.
     
  3. chile elm macrumors newbie

    Joined:
    Oct 14, 2011
    #3
    Having exact same problem - suggestions please?!

    Have tried using a second admin account but get the same problem/error.
     
  4. Ashka macrumors 6502a

    Ashka

    Joined:
    Aug 9, 2008
    Location:
    New Zealand
    #4
  5. chile elm macrumors newbie

    Joined:
    Oct 14, 2011
    #5
    running out of ideas...

    Thank you for the suggestion. I just tried installing the combo update now but got the same result. Getting very frustrated now...
     
  6. china macrumors newbie

    Joined:
    Oct 15, 2011
    #6
    Same problem described above.

    Has anyone tried to contact apple? Same here i doesn't matter if I am doing the update thru the :apple: menu or the files downloaded from apples's servers. I get the message Could not expand file our in the case of tryng to install from file invalid checksum.

    In my case is even worse because I have migrated my services from mobile me to iCloud. Without 10.7.2 synching services aren't working properly.


    Does anyone have any ideas?
     
  7. lighthouse_man, Oct 15, 2011
    Last edited: Oct 15, 2011

    lighthouse_man macrumors 6502a

    Joined:
    Mar 13, 2005
    #7
    Check the files in /Library/Receipts/ If you find the troublesome update, delete or remove from the folder (in case deleting creates a problem) and try to redownload. Read this too:
    https://discussions.apple.com/thread/2522784?start=0&tstart=0

    It would also be wise to restart the computer, go intro recovery mode and repair permissions/verify disk.
     
  8. chile elm macrumors newbie

    Joined:
    Oct 14, 2011
    #8
    Got it to install... finally!

    I decided to try shutting everything down as per the advice i found on another forum after running the repair disk utility and then running the update once more:

    https://discussions.apple.com/message/16359802#16359802

    "I finally fixed my issue. Thank you for the tip about using the disk utilities to repair the disk permissions that worked. The key for my particular computer was to run the "repair disk permissions" on each of my drives then close out of all of the open programs and shut down , NOT REBOOT - and opt not to open any existing windows or programs on reboot. After shutting down I then rebooted, and ran the system update. The software was once again downloaded and I was prompted to reboot so that the update could be mounted. The update both downloaded and mounted without issue."

    miraculously it worked.

    Here's hoping this will work for others!

    thanks all, for the help and suggestions.
     

Share This Page