Can't upgrade to 2.0.2

Discussion in 'iPod touch' started by Philsy, Aug 24, 2008.

  1. Philsy macrumors 6502a

    Joined:
    Jul 29, 2004
    Location:
    South coast of England
    #1
    Hi

    I have a 32Gb Touch and iTunes is still telling me that it's running up to date software at version 2.0, even though I know an update is available.

    Could this be because I (cough) downloaded an unofficial version of v2.0? (You may remember that this was being done a lot on release day because it was taking so long for the official version to appear.) I'm happy to pay for the update but don't know how I can do this.

    Or could there be another reason?

    Cheers

    Phil
     
  2. menthol moose macrumors regular

    Joined:
    Jul 20, 2006
    #2
    If you don't mind paying for it, you could downgrade to 1.1.4, delete all your 2.0 firmware files from your computer, and then upgrade straight to 2.0.2 through iTunes.
     
  3. Philsy thread starter macrumors 6502a

    Joined:
    Jul 29, 2004
    Location:
    South coast of England
    #3
    Happy to do that but how? And will I retain all the apps I've bought?

    Cheers

    Phil
     
  4. PilotWoo macrumors regular

    Joined:
    Jul 14, 2006
    #4
    Yes, that is the reason. You have two choices, downgrade to 1.1.4 (also requires an iTunes downgrade) or locate 2.0.2 touch firmware and use it in the same manner as you did for 2.0. It is easily found with a google search.
     

Share This Page