Can't upgrade to iOS 5.1

Discussion in 'iOS 5 and earlier' started by bige12, Mar 9, 2012.

  1. bige12 macrumors 6502

    bige12

    Joined:
    Apr 6, 2009
    Location:
    Vienna, VA
    #1
    I can't upgrade my iPhone and iPad 2 to the 5.1 update I'm getting a error every time I try to update the software
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    How much storage do you have available on your iPhone and iPad 2? I was down to 1.3 Gig on both of them and while I was able to install iOS 5.1, I was getting errors when I tried "update all" with about a dozen app upgrades showing in the app store.

    I went in settings-general-usage and if you wait long enough, a list of apps in descending order of memory usage shows up and I used this list to delete a handful of data hog apps I didn't really need. Another option is to delete items from camera roll that have already gotten backed up in photostream. On my iPad, I was able to move about 400 meg of files out of goodreader on my iPad to goodreader's iCloud storage area. I can't view them without an internet connection but I got a big chunk of storage back.

    I can think of other reasons the upgrade might fail like a crap internet connection or failure to go on AC power before beginning the upgrade.

    hope this helps...
     
  3. bige12 thread starter macrumors 6502

    bige12

    Joined:
    Apr 6, 2009
    Location:
    Vienna, VA
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    I have like 3.1 gb left on my iPhone, I just think the apple servers are just so overwhelmed and I think I have plenty of room. On the iPad 2 it will even says can't connect to update server, but my iPhone know there is a update
     
  4. Jare macrumors 65816

    Jare

    Joined:
    Jun 17, 2010
    Location:
    Canada
    #4
    It's like I have to post this in every new thread that pops up.

    There's a search function on MacRumors. Use it. Read through the threads, find one that relates to your topic and post in there. Otherwise, create a new thread. There are over 6 threads on this exact issue.

    Did no one read the Forum Rules when they signed up?
     
  5. aygie macrumors regular

    Joined:
    Oct 27, 2007
    #5
    It might be the DNS issue, change the DNS on the phone to 8.8.8.8 and then try and update or try a different wifi network and see if it works.
     
  6. Honbe macrumors regular

    Joined:
    Aug 12, 2011
    #6
    I had the same problem - unable to upgrade, iTunes tried to connect. I have changed DNS settings and the upgrade went thru.
     
  7. Soniko macrumors newbie

    Joined:
    Apr 17, 2011
    Location:
    Lisbon
    #7
    Thanks. It worked now. :)
     
  8. Foxykhat macrumors member

    Joined:
    Nov 12, 2010
    #8
    I have been trying to update my iPad and my hubby's for two days now with the same error. iTunes keep timing with the message the network connection could not be established.

    I know it's not my internet as I was able to update iTunes with no problem

    Help!
     
  9. stisdal macrumors 6502

    stisdal

    Joined:
    Feb 28, 2010
    Location:
    USA
    #9
    Had the issue on my ATV2, changed the DNS and updated right away!

    Thank you for this!!!
     
  10. Lershac macrumors regular

    Joined:
    Feb 21, 2008
    Location:
    Baton Rouge, LA USA
    #10
    Thanks

    Had been trying for days on my ipad2, changed the dns and it worked immediately. Wonder what the deal is?
     

Share This Page