Can't upload HD videos to YouTube! Why?

Discussion in 'iPhone' started by macbook123, Dec 14, 2014.

  1. macbook123 macrumors 68000

    Joined:
    Feb 11, 2006
    #1
    I can't upload HD versions of videos to YouTube because the option

    "HD (Requires Wi-Fi)"

    can't be selected when I'm on WiFi. What am I doing wrong? This is pretty frustrating.
     
  2. macbook123 thread starter macrumors 68000

    Joined:
    Feb 11, 2006
    #2
    Does anybody have an idea what's going on? Is my phone broken?
     
  3. Azzin macrumors 68040

    Joined:
    Jun 23, 2010
    Location:
    London, England.
    #3
    I *think* you have to go into the the camera roll, click on the video, then click the 'Share' button (the up arrow in the bottom left) and select YouTube from there.
     
  4. zorinlynx, Dec 16, 2014
    Last edited: Dec 16, 2014

    zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #4
    Use the free "Capture" app from Google. Lets you upload in HD over cellular and it's much faster than the built in uploading.
     
  5. BvizioN macrumors 601

    BvizioN

    Joined:
    Mar 16, 2012
    Location:
    Manchester, UK
    #6
    For me it seem to only upload on 720p. Is it something to do with a settings or it can only upload 720p?
     
  6. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #7
    There is a setting in the app to upload 1080p.
     
  7. jozeppy26 macrumors 6502

    jozeppy26

    Joined:
    Jul 8, 2008
    Location:
    St. Louis
    #8
    Where are you finding this setting/option?
     
  8. yumsus macrumors newbie

    Joined:
    Mar 16, 2015
    #9
    I had the same problem - this solution worked for me

    DH000 solved it here: https://discussions.apple.com/thread/6593866

    TLDR:

    The problem is that it appears you can only upload to youtube in HD from the photo gallery which is different then the initial view you first come to from the camera.

    See screen shots...the steps are:

    1. Open Camera
    2. View photos
    3. Select "All Photos"
    4. Select Upload button
    4. Now HD is selected
     
  9. sunshine girl5 macrumors newbie

    Joined:
    Mar 2, 2016
    #10
    Yes! This completely worked for me.

     

Share This Page