Can't upload photos to web from iPhoto

Discussion in 'Mac Apps and Mac App Store' started by storybookheidi, Nov 30, 2011.

  1. storybookheidi macrumors newbie

    Joined:
    Nov 30, 2011
    #1
    Hi all,
    I was wondering if you could help me with this issue I've been having. Previously, I was able to upload photos to the web by using the "Media" tab and photos tab and choosing photos from my iPhoto library. Now, when I go to do this, the only folder that displays under iPhoto is "places" which doesn't do me much good. I've been dragging photos to the desktop in order to upload them, but all this copying is messy and I'd rather figure out why this is happening when it used to work just fine.

    I'm using Chrome by the way, and OSX Lion. Here's a screenshot of what I see when I try to attach an image from iPhoto to an email, for example:

    [​IMG]

    Any ideas?

    Thanks,
    Heidi
     
  2. bt22 macrumors 6502

    Joined:
    Feb 15, 2009
    Location:
    Alabama
    #2
    It looks like you are just selecting the wrong photo's folder. If you select the pictures folder in your finder sidebar under favorites, it will give you the iPhoto Library option you are looking for.
     
  3. storybookheidi thread starter macrumors newbie

    Joined:
    Nov 30, 2011
    #3
    That doesn't work. That would try to upload my entire iPhoto library. I should be able to select Photos under "Media" just like I can videos and music.
    This used to work how I explained it...something must have gone wrong along the way?
     
  4. uhuntniki, Aug 12, 2012
    Last edited: Aug 13, 2012

    uhuntniki macrumors newbie

    Joined:
    Jun 26, 2012
    Location:
    East Texas
    #4
    iphoto library opens as one big thing

    I wish that someone would have answered you better, because I have a similar problem. I have a macbook pro running osx10.7.4 and iphoto 11. When I first got my mac six months ago, and synced my pictures for the first time, it gave me an error. It has been giving me the same error ever since 'I photo has discovered that some photos were not imported, do you want to import. If you check ok or no the same thing happens. It takes almost a whole minute to recover them and save them straight in the pictures folder. That is the first problem.

    The second problem is: say I want to upload a picture to my blog or facebook. the site gives me a browser window to upload my .jpg. I go to pictures/ iphoto library, to select a picture, but it doesn't let me select a picture. Instead if I click on it, it tries to upload the 84gig photo library into the one spot on my blog where I wanted the picture. So the only thing I can think of to do is get out of that, open iphoto independently, find the picture i want, save that to somewhere else, like the desktop, then close that, go back to the blog or fb go to the browser window and find the new file I just created and hit enter. WOW! That is how Mac makes things easier? Picasa worked fine for me before. Sometimes I miss windows--in weak moments...

    I know there has to be an easier way, but I haven't been able to figure out what it is. On another thread before, I think I read that my operating system and the iphoto are slightly incompatible is why I get the first problem. I just figured the second problem was linked to the first, and that an update would fix them both, but it hasn't. Please help.
     
  5. pgn macrumors newbie

    Joined:
    May 8, 2014
    #5
    iphoto library is greyed out

    I get a similar problem when I try to upload something from Chrome from iphoto library. The problem is that this is not a proper folder. If I search for a photo under "Pictures" it does find some .jpg's and I can upload them. It seems to be some sort of pseudo folder that once you have penetrated using search it it will access all the items by clicking on the folder on the bottom of the screen but you can't get there by following the tree down.

    Curiously, it works fine on Firefox. I am using Snow Leopard.
     

Share This Page