Can't use headphones while on the network

Discussion in 'OS X Yosemite (10.10)' started by iJayden, Jul 29, 2014.

  1. iJayden macrumors newbie

    Joined:
    Dec 18, 2012
    #1
    Since upgrading to the public beta of Yosemite (didn't have this problem with the Dev Previews) I have been able to use headphones whilst on a network that has an Apple TV.

    The sound will default to my Macbook Pro's internal speakers when no headphones are plugged in, but as soon as I plug my headphones in it will change to either Apple TV and I can't change it back to Headphones in Sys Prefs at all.

    If I want to use my headphones I have to unplug the Apple TV from the wall and turn Wifi off and back on again which is a bit of a pain as I regularly use my Apple TV.

    Has anyone encountered this problem or has a possible fix?
     
  2. bolen macrumors 6502

    bolen

    Joined:
    Jul 22, 2008
    Location:
    Sweden
  3. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #3
    Please report this back to Apple so it can be fixed!
     
  4. bolen macrumors 6502

    bolen

    Joined:
    Jul 22, 2008
    Location:
    Sweden
    #4
    Done!
     
  5. bbfc macrumors 68030

    bbfc

    Joined:
    Oct 22, 2011
    Location:
    Newcastle, England.
    #5
    Can i ask why you installed the PB instead of sticking with the DPs? PB1 and DP4 are identical, apart from the feedback assistant.
     
  6. aldrinjtauro macrumors regular

    Joined:
    Jul 3, 2014
    Location:
    Birmingham, AL
    #6
    I don't think it matters, I've had the same issue on DP4. A temporary solution is to use Boom from the App Store. It's not free, but I had purchased it last year. In order to work as a system-wide equalizer, it installs a special kext/driver-thing that shows up as a sound device called "BoomDevice" in the sound preferences Output tab. As long as you select that device and have Boom running, your headphones will work, regardless of having an Apple TV on the network.
     
  7. bolen macrumors 6502

    bolen

    Joined:
    Jul 22, 2008
    Location:
    Sweden
  8. fanta macrumors regular

    Joined:
    Jun 2, 2011
    #8
    I have encountered a similar problem, though not exactly the same.
    Headphones plugged in worked fine, but whenever i would remove the headphones it would switch to apple tv (when on wifi of course).

    solution was to delete two plists, although i can not find the location anymore. i think it was OS X Yosemite ▸ Library ▸ Preferences ▸ Audio.

    Interestingly, they werent recreated by OSX again. Since deleting them and rebooting, it worked fine again.

    If it helps, please let us know.
     

Share This Page