Can't write .iso to USB drive on MacBook Air (2013)

Discussion in 'MacBook Air' started by onya, Aug 7, 2013.

  1. onya macrumors newbie

    Aug 7, 2013
    Hello, all.

    I'm trying to write an .iso to a USB to create a bootable drive with Tails, but Terminal is not letting me do this.

    This is what happens.

    sudo cat tails.iso > /dev/disk2 && sync
    -bash: /dev/disk2: Permission denied
    I'm certain that /dev/disk2 is my USB, whose format is Mac OS Extended (Journaled).
    I even tried this on another machine (a new iMac) and it didn't work. Any help?

    Thanks a ton.
  2. chrfr macrumors 604

    Jul 11, 2009
  3. Phonzel macrumors newbie

    Jul 16, 2013
  4. onya thread starter macrumors newbie

    Aug 7, 2013
    disk2 is unmounted. I tried it both ways.

    I don't know how I would use Disk Utility to complete this operation...
  5. chrfr macrumors 604

    Jul 11, 2009
    Drag your ISO to the Disk Utility window and it will appear in the sidebar. Then click on the icon for it in Disk Utility and click the "Restore" tab on the right side, then drag your USB disk to the destination.
  6. robvas macrumors 68030

    Mar 29, 2009
    From some old notes I have:

    Run diskutil list to get the current list of devices
    Insert your flash media
    Run diskutil list again and determine the device node assigned to your flash media (e.g. /dev/disk2)
    Run diskutil unmountDisk /dev/diskN (replace N with the disk number from the last command; in the previous example, N would be 2)
    Execute sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img or ./ubuntu.dmg).
    Using /dev/rdisk instead of /dev/disk will be faster.
    If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M.
    If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the 'Disk' and unmount (don't eject) the drive.
    Run diskutil eject /dev/diskN and remove your flash media when the command completes

Share This Page