Can't write to address book

Discussion in 'Mac Apps and Mac App Store' started by hana, Feb 9, 2008.

  1. hana macrumors regular

    Joined:
    May 23, 2003
    Location:
    Los Angeles
    #1
    A few days ago, I found that I was unable to add or edit my Address Book entries. The edit button is completely grayed out. I know I'm doing it correctly because I tried editing entries on my other machine, and am able to do so.

    I also noticed that my Mail program no longer allows me to establish rules. I've looked around for that option on my Mac and I can't find it. I'm running OS X 10.5.1

    Any ideas on how to fix this?

    Thanks
     
  2. hana thread starter macrumors regular

    Joined:
    May 23, 2003
    Location:
    Los Angeles
    #2
    Hello..... any ideas, folks?

    I had another Mac User take a look at my Address Book just to make sure I really do have a problem with the Address Book. Yes, there is no "edit" button that I can use. We think it has something to do with the permissions.

    So now I am going to install Leopard on an external drive (I have one that has data on it that's kinda old and another I've just set up. ) and try to repair the permissions tonight using the external drive.

    Wish me luck and/or give me any of your advise/ideas on how I can fix this.

    Thanks,
     
  3. Editorb macrumors newbie

    Joined:
    Feb 10, 2008
    #3
    For the last few daze, I've been unable to add or edit contacts. Almost all the menu options are grayed.

    I've checked the permissions in get info and I'm set for read/write. However, I don't doubt that my system permissions are toast. Disk Utility has been giving me eight or so permission errors it can't fix since I upgraded to 10.5. I ran DiskWarrior and it fixed a ton of stuff. Then I used Disk Utility and it gave me more permission errors than ever. It fixed them all ... except the eight original ones.

    I'm using an iMac Late 2006.
     
  4. hana thread starter macrumors regular

    Joined:
    May 23, 2003
    Location:
    Los Angeles
    #4
    Well I found this link

    http://forums.macrumors.com/showthread.php?t=388203

    which sort of helped.

    This is what I did:

    Went to (assuming that my account called "HANAs")

    HANAs/Library/Application Support/ Address Book

    Clicked "Get Info"

    Went to "Sharing & Permissions"
    Clicked "HANAs" to make sure that I had read and write access.
    Then also clicked the Daisy or Gear looking icon and had it apply that access to the contents.
     
  5. Editorb macrumors newbie

    Joined:
    Feb 10, 2008
    #5
    Mother of pearl!

    Sweet mother of gravy!

    Perfection.

    I figured it was some simple, crazy, obscure thing.

    Now ... how did it get like that?

    Thanks!
     
  6. brucegoose03 macrumors newbie

    Joined:
    Sep 21, 2009
    #6
    Yeah that worked for me; it seems after updating to snow leopard, the read/write permissions can be corrupted, making it unable to update certain files. In our case, the address book could not be edit, and were unable to edit contacts.
     
  7. elizlarx, Dec 5, 2010
    Last edited: Dec 5, 2010

    elizlarx macrumors newbie

    Joined:
    Dec 5, 2010
    #7
    Changed Permissions and still can't add...

    Solved!! :: Went into Library, App Support, Removed Addy Book folder and then relaunched so it rebuilt the program.


    Not sure if anyone is still on this thread, but I've been having the same issues although I'm on a macbook pro w/ 10.6.5 - It's been like this since I got the laptop. I launch Address Book and have the option to enter First, Last Names & Company but nothing else, and of course it doesn't save the information. I've changed the template and also went in and changed permissions (I wasn't admin, and read-only) but still won't work.

    As above, Disk Utility says:
    ACL found but not expected on "Applications/Address Book.app".

    But also getting:
    User differs on "Applications/Address Book.app", should be 0, user is 501.
    User differs on "private/var/at", should be 0, user is 1.

    And a slew of other Group/ User/ Permissions Differ through Air Port (Permissions differ on "Applications/Utilities/AirPort Utility.app/Contents/Resources/pl.lproj/AAUWirelessPanel.nib/keyedobjects.nib", should be -rw-r--r-- , they are -rw-rw-r-- .
    )

    Any ideas?
     

Share This Page