Cap first letter of sentence and cap "i"

Discussion in 'macOS' started by 8CoreWhore, May 6, 2014.

  1. 8CoreWhore macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
    #1
    any way to get osx to cap the first letter of a sentence and to cap the formal i?
     
  2. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #2
    Shift key?

    It's what I always use.

    Evidence is as above.
     
  3. 8CoreWhore thread starter macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
    #3
    What I mean is - via spell check. Caps are part of proper spelling. For instance, "i". It is supposed to be capped every time. As well as first letter of a sentence. If I type "ohio" with a small "o", it tells me it is supposed to be Ohio. But it doesn't do that in these other cases I mentioned.

    The answer to this isn't, "Duh, don't be lazy, just do it manually." There's a reason we have spell check correction, If I miss it, it should fix it. It's been like this for years and it is a flaw. If it fixes Ohio, etc, it should fix the others.
     
  4. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #4
    OSX does have a spell checker built in, but does not appear to have the capitalization features you desire. Some applications, such as MS Office do have this feature.
     
  5. chown33, May 7, 2014
    Last edited: May 8, 2014

    chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #5
    Which OS version are you specifically referring to?

    The spelling and grammar checks have changed over the releases.

    I just checked on 10.4.11, and it doesn't consider "ohio" to be misspelled. It also has no ability to put initial caps on sentences. At most, it will match the capitalization of the text that it finds.

    On 10.8.4, the spelling check seems both stupider and smarter. For example, it won't suggest USING for USNG because it thinks USNG may be an initialism. This would be stupid IF I'M USNG ALL-CAPS, but smart if I'm referring to the USNG.

    In order to see corrections for initial caps or uncapped i, you have to turn on "check grammar".

    To do this, press command-: (Edit > Spelling and Grammar > Show Spelling and Grammar), then check the checkbox for "check grammar". This is for 10.8.4; what you see may vary if your OS version differs. I don't recall if there's a global setting for this in a System Preferences pane or not.

    FWIW, its recognition of state names seems quirky. "Check grammar" must be turned on to recognize an uncapped "ohio", but an uncapped "arkansas" is always recognized. Maybe "ohio" is a valid non-proper noun in some contexts; I don't know, that's just a guess.
     

Share This Page