Capitalize the letter 'i'

Discussion in 'iPhone' started by webwbr, Feb 7, 2012.

  1. webwbr macrumors member

    Joined:
    Dec 1, 2011
    #1
    I give up (and I did search). How can I get the iPhone (4s) to automatically capitalize the letter 'i' when it is typed and followed by a space? I need this in e-mails, but would also love to have this happen in text messages too.

    Thanks in advance,

    Web
     
  2. MacBookPro13" macrumors 6502a

    MacBookPro13"

    Joined:
    Jan 25, 2011
    Location:
    Ireland
    #2
    Settings > General > Keyboard > Auto Capitalisation > On.
     
  3. nep61 macrumors 6502

    Joined:
    May 17, 2007
    #3
    Also, as you continue to use the spelling the way you want, won't the device automatically suggest that usage in that way?

    I always use the lower case "i" and upper case second letter... however when I first typed "itouch" to someone early on, my iPhone used all lower case letters... after correcting the spelling to my liking 1 or 2 more times... my iPhone now suggests the second letter be capitalized when I type iPod, iPhone, iTouch, iPad etc....
     
  4. webwbr thread starter macrumors member

    Joined:
    Dec 1, 2011
    #4
    Thanks. However, that is how I set mine from day one... but when I type the letter 'i' it does not auto capitalize (in the middle of a sentence).

    and I cannot do a shortcut as it requires more than one letter.

    #confused



    ----------

    I thought that would happen by now too... but after almost 60 days it still doesn't happen.

    Hmmm...

     
  5. eawmp1 macrumors 601

    eawmp1

    Joined:
    Feb 19, 2008
    Location:
    FL
    #5
    There is a "learning" of your usage. If you sent several texts and emails with "i", it reinforces the rule that that is your default.

    I think under General, you can "reset keyboard dictionary" and try to teach it correctly from scratch.
     
  6. sviato macrumors 68020

    sviato

    Joined:
    Oct 27, 2010
    Location:
    HR 9038 A
    #6
    That's likely because there's no such thing as an "iTouch" so the iPhone didn't recognize the name.
     
  7. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #7
    If you have the auto capitalization turned on, I suggest you reset your keyboard dictionary back to default.
     
  8. mattraehl macrumors 6502

    Joined:
    Feb 26, 2005
    #8
    This is probably his best bet. The normal behavior is to change i to I, mine did this right out of the box.
     
  9. webwbr thread starter macrumors member

    Joined:
    Dec 1, 2011
    #9
    OK... I rest the keyboard. I'll report back later if that works. on another note, how do you delete a keyboard shortcut I was hoping after the reset they would be removed, but they were not. In my effort to fix the lowercase 'i' issue I tried a shortcut that did not work.


     
  10. mattraehl macrumors 6502

    Joined:
    Feb 26, 2005
    #10
    Just the standard left-to-right swipe will bring up the delete button for a shortcut.
     
  11. webwbr thread starter macrumors member

    Joined:
    Dec 1, 2011
    #11
    Doh! I'm an idiot. Sorry, but thanks!

    :eek:

     
  12. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #12
    Thank you. Can't stand reading forum posts all in lower case.
     
  13. webwbr thread starter macrumors member

    Joined:
    Dec 1, 2011
    #13
    Thanks everyone for your responses yesterday.

    Since about noon local time yesterday I've been typing, typing and typing emails and texts in hopes that the iPhone will "lean" to auto capital the letter 'i'... still nothing. Does it take several days for this to take?

    So maybe I'm doing it wrong. Does it learn by me typing and self correcting? (i.e. go back delete the i and replace with an I) or by me typing it correctly a certain number of times?

    Thanks in advance,

    :(
     
  14. qtaran111 macrumors member

    Joined:
    Jun 15, 2010
    #14
    Do you have your keyboard set to English? For example if you have another language set but are typing in English, it won't auto correct i to I (depending on the language).
     
  15. likemyorbs macrumors 68000

    likemyorbs

    Joined:
    Jul 20, 2008
    Location:
    NJ
    #15
    Ughhh that's one of my biggest pet peeves. I hate when people say iTouch.
     
  16. YMark macrumors 6502a

    YMark

    Joined:
    Nov 7, 2008
    Location:
    Arizona
    #16
    Can you elaborate? Left-to-right swipe on what/where? :confused:
     
  17. redscull macrumors 6502a

    redscull

    Joined:
    Jul 1, 2010
    Location:
    Texas
    #17
    This is completely incorrect. This has no impact on auto-capitalization of i. For iOS to auto-capitalize i, you have to turn on auto-correction, not auto-capitalization (in that same settings page). I am aware that this seems wrong/backwards when you read what I wrote, but it is accurate nonetheless.

    iOS will also never learned to capitalize i. Not from my experience of having auto-correction off since the debut of iOS 5 and always fixing it manually as I type.

    You can't make a shortcut for it with just the letter, but you can always make a longer shortcut with a smaller phrase, like "ii" turns into "I".
     
  18. webwbr thread starter macrumors member

    Joined:
    Dec 1, 2011
    #18
    Yep.... English > QWERTY > U.S.




    ----------

    Redscull wins! Redscull wins!

    That is it. I never turned on auto-correct as I was afraid of it choosing a wrong word. But turning it on now allows i to be turned into I.

    However, I'm still afraid of auto-correct... but Redscull's idea of having ii shortcut to I is brilliant.

    Thank you all!
    :)

     
  19. mattraehl macrumors 6502

    Joined:
    Feb 26, 2005
    #19
    Auto-correct is amazing, I'm curious what your concern is exactly? I would probably have to type half as slow without autocorrect on.
     
  20. sweetbrat macrumors 65816

    sweetbrat

    Joined:
    Jun 17, 2009
    Location:
    Redford, MI
    #20
    Well, auto-correct does have it's issues http://www.damnyouautocorrect.com/ and I'm guessing it's seeing things like that that's make the OP keep it turned off. But honestly, as long as you pay even a little attention to what you're doing it works great. It learns which words you use most often, which can be very helpful. OP, why don't you try using it for a little while, and then make a decision about whether to keep it turned on or not? You might find that it makes things a whole lot easier.
     

Share This Page