Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

mattopotamus

macrumors G5
Original poster
Jun 12, 2012
14,656
5,861
Anyone know how to turn off this caps lock icon? I use a software where I type in all caps, and if I click the icon it goes away, but it comes back every single time I enable and enable it. It is new in Sonoma.
 

Attachments

  • Screenshot 2023-06-06 at 9.33.49 AM.png
    Screenshot 2023-06-06 at 9.33.49 AM.png
    16.9 KB · Views: 978

tomtad

macrumors 68000
Jun 7, 2015
1,695
4,290
Yep this is new and is colour matched to the tint colour in each app (it's yellow in Notes for example).

There flashing text entry indicator has also been updated and fades in and out now and it's also colour matched
 
  • Like
Reactions: helloapple1

fisherking

macrumors G4
Jul 16, 2010
10,981
5,385
ny somewhere
i like the idea of it (altho it's not there in all places, ie Pages app), but we should have the option to not show it. still, easy to type in ALL CAPS (hmmm, doesn't happen in safari) then click the icon to return to lower case...
 

jbwelsch

macrumors newbie
Jun 28, 2021
24
36
So the icon is a little finicky. In World of Warcraft, it will pop up on the chat box even if you aren't typing, and then it stays there. Might be a problem with game mode, might be a problem with the feature. Definitely want a toggle.
 

precision01

macrumors member
Oct 16, 2014
92
56
This caps lock icon is way too much annoying! This should not be a default feature, but an accessibility feature!
 

precision01

macrumors member
Oct 16, 2014
92
56
We are ready in Sonoma developer beta 5, and still there's no option do disable this annoying caps lock icon. Dumbest idea ever. I can't find a single person who liked it.
 

fisherking

macrumors G4
Jul 16, 2010
10,981
5,385
ny somewhere
i've tried to adapt to it, but it's remains intrusive. i know when i'm typing capital letters because i see them on my screen.. 🤣

need to be able to (globally) toggle this off... (i've reported in feedback assist as well..)
 

precision01

macrumors member
Oct 16, 2014
92
56
i've tried to adapt to it, but it's remains intrusive. i know when i'm typing capital letters because i see them on my screen.. 🤣

need to be able to (globally) toggle this off... (i've reported in feedback assist as well..)
Agree! Perfect conclusion! 😅
 
  • Like
Reactions: AtariMac

fisherking

macrumors G4
Jul 16, 2010
10,981
5,385
ny somewhere
i generally adapt to the OS changes that happen, usually no biggie. but i wish i could disable this.

i KNOW when i'm typing capital letters; i can SEE THEM ON THE SCREEN. the indicator is annoying. hope we get a way to disable this (i asked for it in feedback assistant previously)
 
  • Like
Reactions: coco1231

jdavid_rp

macrumors regular
Feb 25, 2020
224
682
Just came for the same. Its interesting that if you click the icon it disables uppercase but there is no right click menu to disable it...
 
  • Like
Reactions: coco1231

zevrix

macrumors regular
Oct 10, 2012
176
118
i KNOW when i'm typing capital letters; i can SEE THEM ON THE SCREEN.

this icon could be useful to inform the user about accidental enabling of the Caps Locks button so you're aware of it BEFORE you find out that you TYPE IN ALL CAPS inadvertently.

however, this icon is useless for this purpose anyway as it doesn't appear in all apps (as others already mentioned). doesn't appear in InDesign and Word, for example.

so I'll just keep my Caps Lock button totally disabled as I always do (No Action assigned to it in System Settings).
 
  • Like
Reactions: coco1231

JWorld127

macrumors 6502
Jan 12, 2013
414
110
I just found this thread and i am stunned apple still hasnt addressed this or even added a disable option for it. I hate this dam thing popping up.
 
  • Like
Reactions: coco1231

Nermal

Moderator
Staff member
Dec 7, 2002
20,545
3,851
New Zealand
So the icon is a little finicky. In World of Warcraft, it will pop up on the chat box even if you aren't typing, and then it stays there. Might be a problem with game mode, might be a problem with the feature. Definitely want a toggle.
Months later and this is still a problem. I suspect my gameplay performance was affected last night when this thing kept popping up while in the middle of boss fights and distracting me! In my case I'm getting "A" rather than the Caps Lock arrow, but it seems to be the same thing (I have two keyboard layouts).

I've submitted feedback, but we all know that Apple will ignore it unless enough people say the same thing, so I encourage everyone else to log it too.
 
Last edited:
  • Like
Reactions: coco1231

Nermal

Moderator
Staff member
Dec 7, 2002
20,545
3,851
New Zealand
I've now "promoted" my feedback to a proper bug report: in both Discord and Warcraft (edit: and TextEdit) it pops up after exactly 8 minutes without typing. I suspect it actually affects all apps but haven't confirmed that.
 
Last edited:
  • Like
Reactions: coco1231

betazero

macrumors newbie
Jun 19, 2013
8
2
Anyone know how to turn off this caps lock icon? I use a software where I type in all caps, and if I click the icon it goes away, but it comes back every single time I enable and enable it. It is new in Sonoma.
Yikes this needs to be able to be turned off and it should be off by default. Why in the world would anyone need this? The keyboard has a light to indicate this....and has for years!!!
 
  • Like
Reactions: coco1231
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.