Car Bluetooth iPhone 6 failure

Discussion in 'iPhone' started by iBlazed, Sep 20, 2014.

  1. iBlazed macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #1
    I wanted to post this thread as a resource to anyone having issues connecting their iPhone 6 to their car bluetooth systems. I know a few members have brought this issue up on various car models and no solution has been found as of yet. I have already called Apple and spoke to a senior applecare advisor who forwarded the issue to engineering, waiting on a call back from him on monday or tuesday. Please post here if you are having this issue or if you have found a work around.
     
  2. 12vElectronics macrumors 68040

    12vElectronics

    Joined:
    Jul 19, 2013
    Location:
    California
  3. Brandthunder macrumors newbie

    Joined:
    Sep 20, 2014
    #3
    2013 Range Rover

    Have never had any issues with my iPhone and my car. Even running iOS 8 developer for a month or so no issues. Only issue is with the iPhone 6. I can pair just fine but music Or any audio is choppy and cuts out often
     
  4. markel253 macrumors regular

    Joined:
    May 17, 2008
    #4
    With my old iPhone 5 running iOS 7, I was able to get text messages through the head unit on my 2014.5 Toyota Camry Hybrid. It would interrupt my music and read my text message. No problem.

    When selecting bluetooth audio, I would have the option to BROWSE the music on my iPhone.


    Now, with my new iPhone 6 Plus, I have paired it to my system with no problem. All of my contacts on my phone appear and I can make and receive calls with no problem.

    However, the text messages no longer appear on screen when received by my phone.

    BROWSE does not appear on the bluetooth audio screen, although I can select anything on my phone and it plays properly and advances to the next track as expected. I do have over 5K songs, so I am hoping that it may simply be a matter of the system has to index all of them and at some point the BROWSE many again appear. (When connected physically through the USB port, BROWSE does appear as expected. I actually prefer this in the long run as you are able to go directly to any point (alphabetically) on the list this way which you cannot do on the bluetooth connection.


    Any insights?
     
  5. 12vElectronics macrumors 68040

    12vElectronics

    Joined:
    Jul 19, 2013
    Location:
    California
    #5
    Check your PM!
     
  6. Jaide1010 macrumors newbie

    Joined:
    Sep 21, 2014
    #6
    Bluetooth issue

    I am also having the same issue with iPhone 6 and Hyundai Santa Fe. Call is dropped from Bluetooth in the car after 2 rings. Call goes through, but you need to use the phone to talk to someone.
     
  7. odds macrumors 6502

    Joined:
    Aug 7, 2014
    Location:
    Los Angeles
    #7
    I just ordered a new Bluetooth-ready audio receiver for my car. It's the Pioneer DEH-X6600BT. I'll be installing it this week as well as getting my iPhone 6. I plan to report back with my findings.
     
  8. SpasticPat macrumors 6502

    SpasticPat

    Joined:
    Sep 15, 2011
    Location:
    Apollo, Pa
    #8
    Having some issues with it with my ford. I don't have the touch screen, just Ford bluetooth sync. It either doesn't recognize a call is coming in or if it does, when I hang up through the car it doesn't hang up on my phone, still shows the call as going but is dead air. I actually got a few tweets from some Ford Sync service guy who advised me to try doing a global reset on Sync for my car and then trying again. I'm going to try this when I get off of work later.
     
  9. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #9
    Hit "reset all settings" in your iPhone. It's not your cars, it's the phone. This fixed it right away for me. Sorry, should have updated my own thread.
     
  10. NachoGrande macrumors 6502a

    Joined:
    Mar 30, 2010
    #10
    09 Honda Accord, 14Nissan Frontier and 13 Toyota Rav4 all good on my end.
     
  11. hansenc macrumors 6502

    hansenc

    Joined:
    Jun 16, 2004
    #11
    '14 Benz GLK350 and its not working.

    Tried resetting network and settings and re-pairing... no luck

    Worked fine on iOS 8GM on my 5s
     
  12. Nowel macrumors newbie

    Joined:
    Jan 15, 2015
    #12
    Same problem with Toyota Prius, Entune app and iPhone 6+. The connection used to work but after installing the IOS update it stopped working. Now it will pair with other Bluetooth devices, including the Toyota (for music and location) and the Toyota (or other device) will show it is connected, but the iPhone will never show that it is connected nor transfer any data. Yes, Bluetooth is turned on, else it would pair or show Bluetooth status.
     
  13. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #13
    I've a facelifted W212 E400 hybrid and got the same problems as you, but with 8.1.2 on my 6 and 6+.

    It worked fine on my BMW M5 F10 though.

    Probably a Mercedes problem.
     
  14. Ladybug macrumors 65816

    Ladybug

    Joined:
    Apr 13, 2006
    #14
    I had problems getting my Infinity to pair with my iPhone 6. Previously we had 2 4s paired that worked fine. Tried adding my 6 and it could not connect. Once we stopped and my husband took his 4s out of range it paired right up and works without any problems. I have no clue why that is but it works now.
     
  15. Newtons Apple Suspended

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #15
    Instead of calling Apple, I would talk to your dealer. Some have updates they can download to make things work. I was lucky and my 2015 LX paired and works perfectly for phone, music and even Siri! All is good in Lexus land.
     
  16. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #16
    This was only an issue with 8.0 for me. 8.0.2 fixed the issue permanently for me. Forgot all about this thread!
     
  17. Newtons Apple Suspended

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #17
    Glad to hear you got it fixed. I consider my iPhone working with my vehicle are safety factor for sure.
     
  18. AsmaMohd macrumors newbie

    AsmaMohd

    Joined:
    Dec 22, 2014
    Location:
    Pakistan
    #18
    I got my iPhone 6 yesterday, and while all seems well, I can't get it to connect to my car's Bluetooth system. My older 5S running iOS8 does fine, so I don't think is the OS... And, frankly, this is an after market bluetooth set up in my 2006 Murano, but all other phones can connect, just not the iPhone 6.

    There is no manual for the car's system, but I've managed to get it to "search", and while the car does find my phone, there is no way to enter a code on the phone to get it to pair properly. And the phone NEVER sees the BT module in the car to do the pairing.

    Again, this is NOT a iOS 8 problem... but one with the new iPhone 6.
     
  19. pesos macrumors 6502a

    pesos

    Joined:
    Mar 30, 2006
    #19
    6+ worked fine on 3-series loaner.

    On our new X3 pairing was fine but music never starts on its own - regardless of what is on the screen. I have to pull the phone itself out, go to the app, and hit play. Driving me nuts.

    Today took the X3 in for tint and got a 5 series loaner. Paired right up and same problem - every time the car stops and starts again the music is stalled.

    In general I like ios8 but Bluetooth is a F*$*&cking mess.
     
  20. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #20
    Blame iDrive :)

    I've that bug on my F10 M5, but it doesn't really bother me since I barely listen to music.
     
  21. bigskyranger macrumors newbie

    Joined:
    May 15, 2015
    #21
    iPhone 6+ Bluetooth failure

    My wife & both got 6+'s with iOS 8.3 Hers won't link with her Lexus. Mine won't link with my Mercedes. Spent considerable time with Apple phone techs resetting, downloading, all the usual nonsense. Since both cars easily connected with our iPhone 4's, the problem lies within the coding for the iOS 8.3, which, obviously, doesn't execute Bluetooth specifications. The last, senior level tech, then told me that it must be a problem with the Mercedes (and Lexus) firmware. When I told the tech that firmware must also be in my iPad since it doesn't see the iPhone and the iPhone doesn't see the iPad, he politely suggested I contact Mercedes. I've been a computer systems engineer since before Apple was invented. These Bluetooth problems on the discussion boards date back at least 3 year and still no solution from Apple. Best to say, 'We are working on the problem." rather than to point the finger at another vendor. Probably also time to find a programmer who knows what they are doing. Users have long memories.
     
  22. iPad Retina macrumors 6502a

    iPad Retina

    Joined:
    Jan 6, 2013
    Location:
    Canada
    #22
    Have a 2010 W164 ML350, works fine here never disconnects, no text, but works flawlessly
     

Share This Page