Carphonewarehouse iPhone "No Service"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by taylor200588, Jul 11, 2008.

  1. taylor200588 macrumors regular

    taylor200588

    Joined:
    Oct 18, 2007
    Location:
    Arbroath, Scotland
    #1
    my friend ordered an iPhone off carphonewarehouse on monday and it just came today via city link. he got it out the box, pluged it onto iTunes and followed the instructions. Now the phone works fine but he cant get any signal .... anywhere!!

    does he hav to register the sim or contract or something?!?
     
  2. Darkjenso macrumors regular

    Joined:
    Oct 27, 2007
    #2
    my iphone is also still looking for signal although i bought it at O2 this morning, i think that basically 02's servers have been overloaded by the sheer number of activatins at once that their server went down, thats what happened in the store, so we had to register on paper
     
  3. rball1979 macrumors regular

    Joined:
    Jun 6, 2008
    #3
    It can take a while apparently..up to 24 hours they say....as long as it's been activated correctly it'll be fine.
     
  4. neiltc13 macrumors 68040

    neiltc13

    Joined:
    May 27, 2006
    #4
    O2's coverage is rubbish. In my house I struggle to find a signal and it's not much better outdoors.
     
  5. ay98182 macrumors member

    Joined:
    Oct 8, 2007
    #5
    Everything should be ok by this time tomorrow at the latest (other people have had this issue) - it just takes a while for the phone to be registered on o2's system - especially since its launch day at the moment at everything's a mess lol
     
  6. wattso macrumors regular

    Joined:
    Oct 11, 2006
    Location:
    Chester UK
    #6
    I also have the 'No service' thing at the top. Bought from o2. Just one question though, what did you guys do to actually activate the phone with iTunes? All i can remember doing was confirming my apple account information and agreeing to a terms and conditions thing.

    Of note: in the confirmation of address etc. it asked for iphone number, which I do not yet have as i am porting my number and have not yet got a temporary, but this field was auto filled in with my house number, so I just left it. This is ok isn't it?

    Thanks
     
  7. Jase2008 macrumors newbie

    Jase2008

    Joined:
    Jul 9, 2008
    Location:
    Scotland UK
    #7

    i upgraded mine this morning, about 10:30am, UK, and thats all it asked me to do, confirm my apple id and then my address details auto filled.

    after that it went smooth :D
     
  8. RichMacca macrumors member

    Joined:
    Jun 25, 2007
    #8
    Thats how i did it aswell, still no service!
     
  9. wattso macrumors regular

    Joined:
    Oct 11, 2006
    Location:
    Chester UK
    #9
    "After that it went smooth" Sorry I don't understand this statement? Is there more process' involved or do you mean you DO get a signal?

    Thanks
     
  10. C225 macrumors regular

    Joined:
    Mar 29, 2007
    Location:
    Scotland
    #10
    Same here with the apple id then address auto fill in. But then i got a message on the iphone saying unable to complete activation due to no service and has been at no service since.
     
  11. sva macrumors regular

    Joined:
    Oct 8, 2007
    Location:
    Wales, near England.
    #11
    I'm the same, although I got the no activation die to no cell service way before I managed to get iTunes working.

    Filled in my Apple ID details and it's now syncing with no service.
     
  12. r88my macrumors regular

    Joined:
    Oct 28, 2007
    Location:
    Manchester UK
    #12
    Yep in the same boat as you guys with "no service" even though itunes syncs fine. I called O2 but they have given me the same info as others have received, they're very busy and are trying to get them all activated.
     

Share This Page