CarPlay Carplay and steering wheel controls?

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by wav, Jun 6, 2017.

  1. wav macrumors member

    Joined:
    Sep 14, 2012
    #1
    i just took a Mercedes CLA250 for a test drive last night and was a bit disappointed that the steering wheel controls for skipping to the next song didn’t work when listening to music through CarPlay. I could skip to the next track by using the CarPlay interface, but not with the controls on the steering wheel. This surprised me and I wonder if this is how it is on all makes and models with CarPlay or just Mercedes?
     
  2. Stefan johansson macrumors 65816

    Stefan johansson

    Joined:
    Apr 13, 2017
    Location:
    Sweden
    #2
    Was the system factory installed in the car? If it's a third party stereo with car play,things like this could happen.
     
  3. wav thread starter macrumors member

    Joined:
    Sep 14, 2012
    #3
    The system was factory installed - all Mercedes and it was at the Mercedes dealership. Maybe it needs a software update?
     
  4. Stefan johansson macrumors 65816

    Stefan johansson

    Joined:
    Apr 13, 2017
    Location:
    Sweden
    #4
    Possible,but it might also be a hardware problem. Try check if anyone else noticed it. I'm sure that if the technicians working with the system could solve it,if it's reported to them.
     
  5. mariusignorello macrumors 65816

    Joined:
    Jun 9, 2013
    #5
    CarPlay is supposed to use the car’s hardware controls, so like mentioned above, talk to the technician at the dealer.
     
  6. harlenmm77 macrumors 6502

    Joined:
    Nov 5, 2016
    #6
    My steering wheel controls work with skipping tracks and the voice button pulls up Siri.

    Edit, sorry 2017 Hyundai Santa Fe Sport
     
  7. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #7
    Works fine on my '17 Honda Civic.

    I only wish it would show nav directions in the speedometer screen, but other than that, the main screen's CarPlay interface is WAY better than the UI that Honda designed. (not really a surprise)
     
  8. dahauss macrumors regular

    Joined:
    Jul 7, 2009
    #8
    I added a 3rd party carplay radio to my element and connected the steering wheel controls and they work fine. Something had to be wrong with the radio.
     
  9. Ralfi macrumors 68020

    Ralfi

    Joined:
    Dec 22, 2016
    Location:
    Australia
    #9
    2016 VW Golf GTI & steering controls work.

    You should test it in another equivalent model in the yard.
     
  10. genomez macrumors member

    Joined:
    Apr 1, 2006
    #10
    My 2015 Mercedes CLS400 does not allow me to change tracks either. I can use the buttons for Siri and of course the volume controls (including mute) on the steering wheel but not the “up” and “down” arrows for tracks.

    I was disappointed to find that out as well. I should mention that this came preinstalled from the factory in 2016 up and in my car I had the Mercedes retrofit done at the dealership (software update and they swapped my cars USB plugs).
     
  11. AFEPPL macrumors 68030

    AFEPPL

    Joined:
    Sep 30, 2014
    Location:
    England
    #11
    Audi steering controls work, but after 2 days I disabled CarPlay it has to be the worst system I've used for the last 10 years.

    Audis virtual cockpit is leagues ahead.
     
  12. PeteLP macrumors 6502

    Joined:
    Sep 12, 2008
    #12
    The steering wheel controls on the CLA are customizable multi-function buttons. There are arrows on the steering wheel that take you through menus on the dash, which allow you to choose their function. One of those functions is audio-track-skipping.

    Have you gotten to the point where you've chosen audio-track-skipping for the multi-function buttons? If you get to that point and confirm your choice, as described in the manual, I believe they are likely to work with carplay music.
     
  13. AustinIllini macrumors demi-god

    AustinIllini

    Joined:
    Oct 20, 2011
    Location:
    Austin, TX
    #13
    My A4's skipping functions work.

    Wish I had the virtual cockpit, though
     
  14. boston04and07 macrumors 65816

    boston04and07

    Joined:
    May 13, 2008
    #14
    Yup, I have the same car and I couldn’t agree more. I haven’t once used their built in phone connection, only car play. The buttons on the steering wheels work for me as well.
     
  15. 250cla macrumors newbie

    Joined:
    Feb 5, 2018
    #15


    Did you resolve this? I have the same issue and same car.

    I’m hoping the dealer updating the Comand firmware will sort it...
     
  16. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #16
    My 2017 GLS550 is the same way.
    To skip forward I have to use either the "mouse thing" or the circly joystick spinny thingamajig both in the center console.
    Hey Siri works fine but just speaking and normally picks me up the first time I say it, maybe 1 out of 10 it won't or use the voice button on the sterring wheel.
    The rest of the CarPlay expereince is fine but like you I would have liked to just have some button, even those arrow buttons on the wheel able to skip tracks.
     
  17. 250cla macrumors newbie

    Joined:
    Feb 5, 2018
    #17

    It should work, my a class 2017 with audio 20 can control CarPlay with the steering wheel arrow controls to skip tracks etc. My cla 250 is also 2017 but has the Comand system - surely this should be able to do it too.

    I’m going to speak to the dealership today and see if they’ll do a firmware update. Anyone else managed to get it to work?
     
  18. RealEvil macrumors 6502

    Joined:
    Aug 5, 2007
    #18
    Sorry to revive a old thread but I have a 2017 B Class with command and CarPlay. I cannot skip tracks via wheel. The sideways arrows select different options on the instrument cluster display. If I click over to Media via the arrows it simply says that CarPlay is In Control if that.

    Any advice?

    PS it’s same on Android Auto
     
  19. Klae17 macrumors 65816

    Klae17

    Joined:
    Jul 15, 2011
    #19
    Can't skip tracks on the steering wheel either, very big oversight
     
  20. PeteLP macrumors 6502

    Joined:
    Sep 12, 2008
    #20
    Here's an important test that could shed some light on your situation. Please try playing audio via bluetooth only. For that test, disconnect CarPlay completely.

    Do you still have problems skipping tracks?

    Also, in which audio apps have you tried have you tried skipping tracks, and what is the make, model and year of your car?
     
  21. Klae17 macrumors 65816

    Klae17

    Joined:
    Jul 15, 2011
    #21

    Bluetooth audio works with the steering wheel. No app works for skipping when in CarPlay (audiobooks, music, no scrolling) 2017 MB E Class. Thank you
     
  22. Bazooka-joe macrumors 68020

    Bazooka-joe

    Joined:
    Mar 12, 2012
    Location:
    Swindon, England
    #22
    Same with my 2018 Merc SL with factory fitted CarPlay as standard. Siri and volume work fine. Disappointing really
     
  23. PeteLP macrumors 6502

    Joined:
    Sep 12, 2008
    #23
    This is a long shot, but worth looking at. Previous models of the E-Class had steering wheel controls which needed customization through the menu system to provide skip forward and back functionality. They provided DIFFERENT functionality by default.

    These newer e-class touchpad steering wheel controls may not have that kind of customization, and the fact that it's already working with bluetooth on your car seems to indicate that it's already set up for that, if it does. BUT

    There's IS some small chance that you can customize that steering wheel touchpad gesture for skip back through the menu options, AND that the customization is specific to the input source. (which would mean that the bluetooth and carplay functionality could be customized separately)

    To check this out, I would try looking through the touchpad menu system for settings WHILE carplay is turned on.

    Worth a try.
     
  24. Pipper99 macrumors 68020

    Pipper99

    Joined:
    Aug 14, 2010
    Location:
    Fort Worth, TX
    #24
    I have a 2013 Jeep Wrangler Unlimited, and I'm wondering if the steering wheel controls will work. Of course, the seller/installer promises they will work, but I have my doubts. I'm considering the Kenwood DDX9905S.
     
  25. ColoArtist macrumors regular

    Joined:
    Jul 3, 2012
    Location:
    Denver, CO
    #25
    I went over to Crutchfield and put in your car and the radio. You didn't mention whether your Jeep has the stock Alpine system or not...it makes a bit of difference but not for the steering wheel controls. They'll work, but as in most cases it takes a 3rd party adapter. Their recommendation is an iDataLink MDS-MRR.

    When I did an install in my 2008 CRV I used the recommended adapter from iDataLink. It's a slightly different model, but I expect it's similar in set up and function. The set up was kinda archaic...the control module needs to be flashed for the settings and the software only supports Windows and Explorer. I managed it with an emulator on my Mac, but it had to be Windows 7, 10 wouldn't work, and it had to be Explorer, not Edge. On my car the adapter has worked without fail. Plus it added some new functions which the car didn't have such as a display showing the tire pressure for each tire.

    There were some warnings about dash modifications which would need to be done on your car, so I'd suggest you go to Crutchfield and check out their recommendations.

    Also, since the steering wheel buttons are programable, you might later on decide to change them. It's kind of a pain in the butt to do in that the module needs to be connected to a computer, the changes made on the iDataLink web site, and then the new configuration flashed to the module. Probably something you'd want the installers to to. So not only check with them what adapter will be used, and what features are/aren't supported (like the stock USB port), but also how much would they charge you for any configuration changes in the future.

    Best o' luck with it.
     

Share This Page