Auto CarPlay: I don't want music to start playing every time I start my car!

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by dmk1974, Jun 18, 2017.

  1. dmk1974 macrumors 68020


    Sep 16, 2008
    Is there a way to disable this? I have a 2017 CR-V and every time I start my car and plug in my iPhone, it starts playing music. I don't want music to play until I tell it to start to play. Is there some hidden way to disable this? And no I don't want to just turn down the volume to zero all the time :) Thanks!
  2. Ratatapa macrumors 6502a

    Apr 3, 2011

    If it's like me, just change the source exemple to radio before unpluging your phone
  3. CTHarrryH macrumors 68000

    Jul 4, 2012
    Same for me - it goes back to doing what I was doing when I shut down car. Same as car built in audio - what I was using starts again. I would assume this is as designed - same as builtin car audio
  4. dmk1974 thread starter macrumors 68020


    Sep 16, 2008
    I guess that workaround works. I set mine to the XM channel to 0 or 1 (the one that has the code on it). Still dumb that a disable autoplay isn't available.
  5. jgelin macrumors 6502a


    Jul 30, 2015
    St Petersburg, FL
    I think in the iOS 11 beta the music doesn’t start until you tell it. It doesn’t change my radio over to CarPlay screen in Honda Civic until I navigate to the source screen. Prefer this action much more.
  6. boston04and07 macrumors 65816


    May 13, 2008
    I hope this is the case. I love having carplay but the automatic starting of audio is the one thing that drives me nuts about it. Especially since, in my unit at least, I can't access the screen to pause it for a few seconds or so after my car starts as the unit's display is loading.
  7. julieknits macrumors newbie

    Apr 22, 2010
    There's a song in the iTunes store called "A a a a a Very Good Song." I've added it to my music library and anytime the iTunes library starts in the car automatically, it plays this blank song. So no repetition of Hamilton's Aaron Burr song to drive me up a wall.
  8. Sean7512 macrumors 6502a

    Jun 8, 2005
    In my Jeep Grand Cherokee, I can go to settings and turn off "Auto Play" and then when plugging my phone in, it won't even launch CarPlay, I have to manually open it up.

Share This Page