Carrier update error

Discussion in 'iPhone' started by ReleasedAce, Sep 25, 2009.

  1. ReleasedAce macrumors newbie

    ReleasedAce

    Joined:
    Apr 15, 2009
    #1
    Tried to update. Carrier settings mms update through iTunes it gives me a message saying " iTunes could not update the carrier settings on your iPhone. An unknown error has occurred (0xe800003d)." what is it and how do I fix it?
     
  2. tiresias314 macrumors member

    Joined:
    Jul 11, 2008
    #2
    I get the same thing. Are you jailbroken as well?
     
  3. JUSTQUAN macrumors member

    Joined:
    Jul 3, 2009
    #3
    i spoke with a rep from att/iphone and he said i needed to upgrade to 3.1 in order to enable mms. im not doing that. i know this may be wrong so can someone else confirm this?? i dont think i have to upgrade just to do this.

    im rocking 3.0 jailbroken and itunes 8.
     
  4. Stevo1228 macrumors newbie

    Joined:
    Sep 25, 2009
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Mobile/7C144)

    U have to update to recent software
     
  5. ReleasedAce thread starter macrumors newbie

    ReleasedAce

    Joined:
    Apr 15, 2009
    #5
    Was jailbroken I updated to 3.1. And it's doing it I'm going to try s restore and see what happens
     
  6. MotownGuy macrumors newbie

    Joined:
    Sep 25, 2009
    #6
    Carrier Update for Jail Broken Phones

    Make sure that the you do not have the AT&T Logo that can be downloaded from Cydia installed on jailbroken iPhone. You will not be able to update the carrier file.
     
  7. tiresias314 macrumors member

    Joined:
    Jul 11, 2008
    #7
    Everyone having this issue: did you install the AT&T carrier logo package within Cydia?

    I had it installed on my JB 3.1 3G, I removed the package, rebooted and was able to update the carrier settings.

    I'd say pretty conclusively that the AT&T carrier logo package (or perhaps any package that modifies the carrier logo's appearance?) causes that issue.
     
  8. savior1974 macrumors regular

    Joined:
    Feb 17, 2009
    #8
    Correct. It was included in the how to thread.
     
  9. Hunts121 macrumors regular

    Hunts121

    Joined:
    Mar 21, 2005
    Location:
    Massachusetts
    #9
    can you put the cydia package back after the carrier update is applied?

    EDIT: I haven't reinstalled the package yet, but the carrier update worked right away after removing it and my MMS works fine.
     
  10. emerzoncs macrumors newbie

    Joined:
    Sep 25, 2009
    #10
    The same Message

    :eek::eek::eek:I get the same massage i have an iphone 3GS 32GB i try to update the carrier setting but I get the same error any sigestion to fix this problem I jailbreak my iphone on the 3.0.1 version and then I updated today to the 3.1 update but when I try to install the carrier update i get this error. i need help please I want to try it..itunes could not update the carrier setting on your iphone An unknow error 0x800003D
     
  11. Argelius macrumors 6502

    Argelius

    Joined:
    Jun 16, 2005
    #11
    Same issue.

    I have a 3GS phone that was previously jailbroken. But when 3.1 came out I decided to forego the jailbreak and did a clean install (as a new user). So I'm not currently jailbroken.

    Anyway, I also get the "iTunes could not update the carrier settings" when I attempt to download/install the new MMS settings.

    Hmmm.....
     
  12. chisss macrumors newbie

    Joined:
    Jun 23, 2009
    #12
    Same here, I had a JB 3.0 with that AT&T logo thingy then I upgraded to 3.1 with the official FW and it's been fine up until now. i can't update teh carrier settings.
    This sucks... I am guessing that carrier logo is stuck there somewhere even with the official 3.1 FW
     
  13. Argelius macrumors 6502

    Argelius

    Joined:
    Jun 16, 2005
    #13

    Well, the last thing I tried worked.

    In iTunes I did a Restore. As soon as that process finished, the "there's an update available" message popped up -- this time it downloaded okay without the error message.

    For what it's worth, I was previously jailbroken as well. When the 3.1 OS came out I decided to bag the jailbreaking and did a restore cuz I was wondering if it was why my battery life s*cks (it wasn't -- it still does).

    Anyway MMS is now working.
     
  14. chisss macrumors newbie

    Joined:
    Jun 23, 2009
    #14
    funny thing is I was just going to post that...lol it's working for me too after the restore:D
     
  15. Argelius macrumors 6502

    Argelius

    Joined:
    Jun 16, 2005
    #15
    Of course, I have yet to get a (Picture) MMS to actually send. The sending progress bar gets about 95% finished...then sits there for 30 seconds, then says 'message could not be sent'...
     
  16. chisss macrumors newbie

    Joined:
    Jun 23, 2009
    #16
    That's odd, mine works. Are you on 3G? or Edge? I know if you are on Edge it has issues because it's slooooooooooooow
     
  17. Argelius macrumors 6502

    Argelius

    Joined:
    Jun 16, 2005
    #17
    Yep. I'm on 3G (also tried it on WiFi...).
     

Share This Page