Casio Digital Camera video .avi file audio only in QuickTime

Discussion in 'Mac Apps and Mac App Store' started by purpleinnej, Aug 8, 2012.

  1. purpleinnej, Aug 8, 2012
    Last edited: Aug 10, 2012

    purpleinnej macrumors member

    Joined:
    Feb 8, 2010
    Location:
    Navarre, FL
    #1
    I have a MacBook Pro with Mac OS X 10.5.8
    I imported photos and videos from a Casio Exilim camera via USB to iPhoto
    Pictures are as expected
    Videos are .avi files, which automatically play in QuickTime. However, only the audio plays, no video.
    Downloaded CASIO avi importer.component from manufacturer, unzipped, and moved .component file to HD>System>QuickTime folder, restarted.
    Still only getting audio, no video. Suggestions?
     
  2. purpleinnej thread starter macrumors member

    Joined:
    Feb 8, 2010
    Location:
    Navarre, FL
    #3
    ***solved***

    Thanks! Perian didn't work, but VLC did. Also, thanks for the article on how to make VLC the default program. AND of course, for the super-quick response!!
     
  3. purpleinnej thread starter macrumors member

    Joined:
    Feb 8, 2010
    Location:
    Navarre, FL
    #4
    iPhoto not using default player

    I have VLC set as the default program to open .avi files and if I open them from finder, they open with VLC correctly. But if I open from iPhoto they still open in QuickTime (with audio only). Any way to fix this in iPhoto settings? I've found some OLD threads (4-5 years old) that suggest there's no solution, but can't seem to find anything more current.
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #5
    Not that I know of, since iPhoto is bound to use QT Player. Maybe we should find out, what codec the .avi file is using in order to get QT Player to recognise it.

    In order to find out, what codec your video is using, you can use the following three applications to analyse a sample video file.
    When done, you can use the "Report" (VideoSpec) and "Export" (Media Inspector) button to export a report,
    attachable to your next post via the [​IMG] button.
    In MediaInfo you have to go to the Menu Bar, select View > Text and copy the text via CMD+A > CMD+C and paste it via CMD+V into your next post.
     
  5. purpleinnej thread starter macrumors member

    Joined:
    Feb 8, 2010
    Location:
    Navarre, FL
    #6
    Yes, my ultimate goal is to be able to play them directly from iPhoto, which appears to mean I *HAVE* to get them viewable in QT. Although it is nice to know that I can play them directly from Finder with VLC if I have to (but that sounds like a gigantic pain since I have been using iPhoto to organize everything up until now and the purchase of the new camera).

    VideoSpec report attached.
     

    Attached Files:

  6. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #7
    As far as I can see, the .avi file is using a widely used video codec (Motion JPEG), but the audio codec (MS IMA ADPCM ) is less used, thus I don't understand, why Perian does not allow QT Player to play the file.
    Do you have Perian properly installed and opened a Casio .avi file in QuickTime Player 7 instead of QuickTime Player X?
     
  7. purpleinnej thread starter macrumors member

    Joined:
    Feb 8, 2010
    Location:
    Navarre, FL
    #8
    I have QT 7.7. I have no idea if I have Perian installed correctly or not. I have Perian.component in the HD>Library>QuickTime Folder (along with a bunch of other codecs I've gotten trying to solve this). Is there anything else I need to do to get it installed correctly?
     
  8. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #9
    Look at System Preferences > Perian to see, if it is installed.
     
  9. purpleinnej thread starter macrumors member

    Joined:
    Feb 8, 2010
    Location:
    Navarre, FL

Share This Page