Catastrophic OSX Failure + Unable See Time Machine Backups

Discussion in 'Mac Basics and Help' started by flat6, Jun 1, 2011.

  1. flat6, Jun 1, 2011
    Last edited: Jun 1, 2011

    flat6 macrumors regular

    Joined:
    Oct 24, 2004
    #1
    Long rant of OSX / Time Machine fail of epic proportions. In short, I can see my Time Machine backups, but can't get my MacBook Air to restore from those backups.

    ...

    So after 3 years of ownership my MacBook Air decided to flip its **** and catastrophically fail - some essential OSX files got corrupted (I was just surfing yahoo.com at the time, and bam, instafreeze; upon reboot, the system would flash that awfully mysterious blinking-question-mark-folder and refuse to go into OSX).

    No worries I thought, just pop the OSX Install Disc into the USB-plugged SuperDrive and run the HD repair utilities. Total fail, the utilities couldn't repair HD. Ah well, no worries I thought again, I'll just erase the HD and then reinstall OSX, since I religiously keep Time Machine backups so I can easily restore my system - what could possibly go wrong? The HD erase went fine (the hardware itself works).

    Well, I wanted to restore from Time Machine right there and then from the OSX disk utilities / reinstall but hey, the MacBook Air has only one ****ing USB, so I couldn't have both the SuperDrive OSX Install / Utilities Disc and the external HD with the Time Machine backup going at the same time. (Yes, I tried also the DVD/HD-sharing Remote Disc software, but my MacBook Air refused to see that disc - fail.)

    No worries I thought again, I'll just use Migration Assistant post-OSX-reinstall to get my old stuff back from the Time Machine backups. So I go in, update all the OS-stuff (so that both the reinstalled OSX and the backups were in the same hardware/OS state), and go into Migration Assistant. Lo and behold, it refuses to see any Time Machine backup on the external HD - just keep spinning its 'thinking' animation on-and-on-and-on. I check the external HD itself, and of course the Time Machine backup files are in there. I enter Time Machine (the 'Star Wars' view) and of course the backup files are in there. But Migration Assistant can't see it at all. So I try to click on my HD in Time Machine and click "Restore". It moves some 60 GB of backups to the MacBook Air, but it's not a restore - no, the new OS and its account doesn't see ANY of it. 60 GB of HD space is gone, so the backup was successfully copied/restored somewhere - just not anywhere I can access. Fail fail fail. Totally confusing piece of software design.

    And the cherry on top is that while I was trying to restore my system, Time Machine had the bright idea to make a NEW backup - from the freshly installed OS. (Why, Time Machine, why? It's a new OS install. There's NOTHING THERE. I tried to cancel it but there's no easy way to schedule/disable automatic backups - just the option to delay it for a few minutes. **** you very much for that lack of options Apple.) Anyway this new backup made by Time Machine thoroughly confuses the Migration Assistant, to the point that it can now see a Time Machine backup! But what it can see is just the useless new backup of the new OS install... it still can't see the real backups that I want to restore.

    So, in short, I can see my Time Machine backups but can't access them, since Time Machine and/or Migration Assistant appear to be total pieces of ****. To salvage my music and photos I had to resort to pulling them off of my iPad (using 3rd party software I had to pay for - **** you iTunes for not allowing the option to pull ALL photos and music back off an iPad) - but some of my photos were only on my MacBook Air and its external HD Time Machine backups, so now I'm wondering how to pull them off. (To add to the long list of fails, I apparently can't even access my own Time Machine backups manually to get those photos, since they're protected folders that deny me access to my own backups, though I'm still looking into ways around this.)

    I'll be replacing Time Machine with something else. What do people recommend? CarbonCopy seems like it may do the trick nicely. I'm also eternally thankful to Dropbox, since that's where I had my most important files - in the cloud. I'll be looking to move my music and photos there too now.
     
  2. Les Kern macrumors 68040

    Les Kern

    Joined:
    Apr 26, 2002
    Location:
    Alabama
    #2
    I have had success, 100% of the time, pulling files directly from the Time Machine backups directories without entering TM. So maybe try installing a fresh OS, hooking up the drive, then dragging and dropping your docs and music library.
    Worth a try.
     
  3. MacForScience macrumors 6502

    MacForScience

    Joined:
    Sep 7, 2010
    Location:
    USA
    #3
    I'm sorry I don't mean to through gas on your little fire here but this is totally operator error. I am sorry you lost your data.

    When you do a restore like what you describe you have to disconnect the drive and install your OS then plug it back in click cancel at the dialog to use as a backup drive then go to migration assistant and select restore.

    You do realize that they make USB hubs for this very reasons so you can have two or more USB devices plugged in at the same time.

    I have used TM and Migration Assistant for the very task you have described on many computers both mine and others and have never had this issue.

    Cheers
     
  4. Fishrrman, Jun 2, 2011
    Last edited: Jun 3, 2011

    Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #4
    The original post is but one more of numerous postings I've seen in this forum, that demonstrate why Time Machine SHOULD NOT be used by most folks.

    To the original poster:
    I'm sorry you lost your data, but NEXT TIME do it differently.

    - Get CarbonCopyCloner from bombich.com (it's absolutely free)
    - Use CCC to make a "bootable clone" of your internal drive.
    - Once or twice a week, use CCC to do an "incremental backup" of your drive to the clone.

    If you do this, you will always have a "pretty close copy" of your internal drive, IMMEDIATELY BOOTABLE AND ACCESSIBLE. You can boot from your backup and get going again, and work to fix the problems with your internal drive.

    There are two fatal faults of relying on a TM backup:
    1. You can't boot from it -- no way, no how, and...
    2. The files in the TM backup ARE NOT in POFF (plain old finder format). This can present problems trying to access them "in a moment of extreme need".

    Time Machine purports to "make backing up easy". And so it does.
    The problem with TM is that trying to GET AT those files, once "backed up", ain't so "easy".

    With a CCC cloned backup, you just connect the backup drive and boot from it. That's all there is to it.
     
  5. flat6 thread starter macrumors regular

    Joined:
    Oct 24, 2004
    #5
    Cheers, will give that a try.

    Did that, and, as I wrote, the migration assistant "refuses to see any Time Machine backup on the external HD". Blank screen with spinning/thinking wheel instead. User error? Really dude?

    You do realize they don't work with SuperDrives/MBAs: http://forums.macrumors.com/showthread.php?t=436990

    Good stuff, I'll use that from now on. Thank you.
     

Share This Page