Cause of Mountain Lion install failure on mid-2010 white MacBook?

Discussion in 'MacBook' started by Daysight, Aug 17, 2013.

  1. Daysight macrumors regular

    Joined:
    Dec 15, 2011
    #1
    Whenever I try to install Mountain Lion on my mid-2010 unibody white MacBook A1342, the install hangs at about 18 minutes. I have tried a variety of approaches based around downloading my purchased copy of Mountain Lion from theMac App Store two different ways:

    1. Direct from the App Store to the MB.
    2. Booting the MB into ML from an external hard drive, zero erasing the hard drive and repartitioning, then installing Mountain Lion from that external hard drive after downloading the installer to that external drive using my iMac.

    We lost the original disks that came from Apple with this MB (I know, I know ... kids). Apple sent me a Snow Leopard install disk, because that is the OS that came with this MB originally.

    3. I booted the MB from the SN disk, repartitioned and zero erased the MB's internal hard drive, and installed SN. Then updated SN and tried to install ML. Same install failure: hung at 14-18 minutes.

    So the MB can install and run both SN and L just fine.

    I also tested the ability of the MB to install ML from one external drive to another external drive:

    4. Booting the MB from the external hard drive, launching the ML installer there and directing it to install on a new external USB thumbdrive: hung exactly the same way).

    So, did that last test rule out the MBs' internal hard drive as the source of the problem?

    I verified the hard drive using Disk Utility: no problems detected.
    I ran memtest: RAM seems fine.
    I reset PRAM and SMC: same install hang.

    I restored the MB to Lion using my Carbon Copy Cleaner clone and it seems to be perfectly usable with L, but I want it to run ML, and I want to upgrade to Mavericks next month.

    Apple store is 4 hours away, and I am reluctant to pay $300 to send it to a repair depot for diagnosis. Hoping to solve it myself if I can.

    Thanks for any thoughts.
     
  2. 53kyle macrumors 65816

    53kyle

    Joined:
    Mar 27, 2012
    Location:
    Sebastopol, CA
    #2
    Have you been re-downloading the installer every try? If not you could try downloading a new copy as the one you've been using could be corrupted.
     
  3. Daysight thread starter macrumors regular

    Joined:
    Dec 15, 2011
    #3
    Yes thanks, I have re-downloaded several times, both on my iMac and on my MacBook.
     

Share This Page