CAUTION: Apple Remote Desktop 3.7.0 Update

Discussion in 'OS X Mountain Lion (10.8)' started by Frost7, Oct 23, 2013.

  1. Frost7 macrumors regular

    Frost7

    Joined:
    Oct 15, 2012
    Location:
    Republic of Texas
    #1
    A word of warning to anyone else who remotely administers Macs. The 3.7.0 ARD update that dropped alongside Mavericks screws up ARD's ability to communicate with ARD Client through OSX's built-in firewall. Even if you have everything configured properly, it'll block it anyway.

    Makes Macs that upgrade from ARD Client 3.6.2 to ARD 3.7.0 unreachable unless you completely turn off the firewall.

    Haven't found a workaround yet that doesn't involve the firewall being turned off.

    This is under 10.8.5 Mountain Lion. I'll be updating one of the machines to Mavericks shortly; I doubt that will change ARD's behavior, but we'll see.
     
  2. BenL macrumors newbie

    Joined:
    Oct 25, 2013
    #2
    reported to Apple engineering

    I talked to tech support at Apple and reported that "ARD 3.5.3" on OS X 10.6.8 does not work with "ARD 3.7.0. client" on OS X 10.8.5

    They said that they were passing the issue on to engineering.
     
  3. skogarfoss, Oct 25, 2013
    Last edited: Oct 25, 2013

    skogarfoss macrumors newbie

    Joined:
    Oct 5, 2012
    #3
    workaround

    Not even ARD is blocked on my headless MacMini, also my latest ipad-screens-app will now be blocked with firewall on.
    Downgrade from 3.7 to 3.6.2 did not work.

    I found three workarounds. Two work with ssh-connections:
    For my iPad:
    http://help.edovia.com/kb/ios-general-troubleshooting/apple-remote-desktop-361-issues-updated (also works with my 362 version)

    For my mac:I use "Jump Desktop" with a SSH-Server (remote-login must be active)

    the third one is to turn firewall off/on with a applescript (e.g.with a mail rule; see attachment) and then open ard.

    and maybe there is a fourth way (maybe) I reinstalled ard 3.7 on my Mavericks-PowerMac, reinstalled 3.6.2 on my Mountain-Lion-MacMini and now it works again - as if nothing happened...
     

    Attached Files:

  4. dudemanla macrumors newbie

    Joined:
    Jul 5, 2009
    #4
    remote desktop client update 3.7.0 in Mavericks

    Can anybody please tell me why I am getting an update available in Mountain lion for remote desktop client 3.7.0? I don't even have Remote Desktop installed so why would this be coming up
    I said mavericks but I meant to write M. Lion in the title of this post
     
  5. BenL macrumors newbie

    Joined:
    Oct 25, 2013
    #5
    ARD Client is part of the base install for OS X (controlled with Remote Mgt. under Sharing)
     
  6. mcseufer macrumors newbie

    Joined:
    Oct 30, 2013
    Location:
    Columbus, Ohio
    #6
    Assuming Apple Remote Desktop has been updated to 3.7 on client and server machines:

    On the Mac you want to connect to:

    • System Preferences -> Security & Privacy -> Firewall Options -> Locate screensharingd, highlight it and remove it via the subtraction symbol - > Click OK
    • System Preferences -> Sharing -> Untick "Remote Management" -> Close window -> Re-open Sharing window -> Re-tick "Remote Management"
    • You'll be prompted about allowing incoming connections from "screensharingd" -> allow incomming connections -> close window

    This should enable ARD to connect with Mac OS X's built-in firewall turned on.

    Note: Not sure if ALL of these steps are needed, but this is what worked for me.

    I suspect Maverick's ARD preferences files were modified or preference locations might have been changed and initial settings weren't copied over correctly when we updated from an earlier Mac OX version to Mavericks. Pure speculation there, however.

    Hope this helps everyone.

    Michael
     
  7. BenL macrumors newbie

    Joined:
    Oct 25, 2013
    #7
    There is no problem with ARD 3.7 and ARD client 3.7

    The problem is with earlier versions of ARD and ARD client 3.7

    Those of us still running OS X 10.6.8 can only run ARD 3.5.3 which is SUPPOSED to be able to work with the 3.7.0 client.

    ARD 3.6.2 client works fine on OS X 10.8 so it seems not to be a problem with the OS.

    I expect to see ARD client 3.7.1 in the not too distant future.
    PS - insert your favorite value for "not too distant" :)
     
  8. Drharrington macrumors member

    Joined:
    Jan 1, 2012
    #8

    After reboot -- this worked !! Thanks :)
     
  9. Lukehart macrumors newbie

    Joined:
    Feb 11, 2005
    #9
    Not being prompted "to allow incoming connections" when ticking Remote Management. Can someone remind me what other setting is needed to show this prompt?

    Thanks,

    ~ Lee
     

Share This Page