Caveat for iOS 11 Public Beta & wOS 3 users

Discussion in 'Apple Watch' started by Julien, Jul 3, 2017.

  1. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #1
    There is a bug in iOS 11 (has ben reported by others too) when using wOS 3 (not sure if it affects wOS 4) that can cause your :apple:Watch to lose it's connection to your iPhone. It will not show up under BT connection and there is no way to reconnect it without un-paring (losing all data since it became disconnected)/re-paring. When this happens things also get really wonky. For me yesterday I first noticed that my iPhone didn't unlock my :apple:Watch. While home it gave no indication of not being connected. When I left home to the gym noticed the "not Connected" red icon.

    When I got back home I tried every combination of restarting/rebooting/switch toggling/swearing etc. I could get a partial connection (see pic with weird data & also took some shots from my watch but were lost in re-pair) of some sorts but it didn't show up under BT Settings or reliably transfer data.

    Luckily I had enough time in the day to get all my Stand (5 hours lost), Move (again) & Exercise (again).


    IMG_2912.jpg
     
  2. slappypig macrumors member

    slappypig

    Joined:
    Jun 26, 2015
    Location:
    Earth
    #2
    I have a similar situation where the watch doesn’t appear in my BT settings though I have a MAC address in my BT settings that says it’s not connected (which turns out to be my watch). Other than this I have lost zero functionality between the two devices.

    All of my workouts, heart rate monitoring, etc has worked as it did before with no issue. I am able to transfer pictures, songs and modify watch faces directly from the app on the phone with everything transferring / working as it should on the watch.

    Odd.
     
  3. Broken Hope macrumors 6502

    Joined:
    Jan 15, 2015
    #3
    That’s how mine was behaving, working fine but showing as an on connected MAC address in Bluetooth settings on my phone.

    I was able to unpair and repair and not lose any data and it shows fine under Bluetooth now.
     

Share This Page