CD _Not_ ejecting

Discussion in 'iMac' started by Industries, Oct 22, 2008.

  1. Industries macrumors newbie

    Joined:
    Jun 12, 2008
    Location:
    North Carolina
    #1
    hi all.

    I have the latest Mac mini, owned it for about 6 months now. The cd drive is messing up now. whenever i try and eject a cd, it tries to eject it but it just goes back in the drive. whenever i look inside the little opening in the mini, it doesn't even seem to be getting that far.

    the only thing i can think of is it being misaligned with the case of the mini. how do i fix this? i'm comfortable with taking it apart, but i don't want to spend ANY money on actually taking it apart.

    if you need any more details ask, i've tried ejecting it about 20-30 times now and it still won't eject.


    Joseph
     
  2. Reflow macrumors 68000

    Reflow

    Joined:
    Mar 30, 2005
    Location:
    NJ/PHL
    #2
    Call up apple care. I wouldn't open it up unless you don't have apple care b/c if they notice you tried to open it up they will void the warrantee.
     
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
    Honestly, as good as AppleCare techs may be, I doubt this is something they'll be able to fix over the phone. If your mac mini is only 6 months old, you're covered under the initial 1 year warranty, so bring it into an Apple Retail store or a service provider you can look up on http://www.apple.com/buy/locator/service/ and let them take a look.
     
  4. Industries thread starter macrumors newbie

    Joined:
    Jun 12, 2008
    Location:
    North Carolina
    #4
    OSHT OSHT OSHT

    i thought warranty = support, and so i opened the case (i was being stupid, if i really thought about it i would've realized it). will they still fix it, even though i've opened it?

    btw, i fixed it, there was this black stuff inside my cd/dvd drive and i took it out. now it actually ejects cds and reads them and what not, but now i can't boot from my leopard dvd. it starts with the apple screen (it actually boots from the cd), but then before the spinning wheel the cd ejects and then it continues booting opensuse (don't ask).

    it seems to have a lot of scratches on it, and i've already had it resurfaced twice. might this be the issue? i'm going to get it resurfaced in a little while. hope it helps!
     

Share This Page