CD/DVD Not Recognized in Virtual machine

Discussion in 'Windows, Linux & Others on the Mac' started by Moonraker069, Dec 28, 2008.

  1. Moonraker069 macrumors newbie

    Joined:
    Dec 28, 2008
    Location:
    Florida
    #1
    I have a new (12/2008) Mac OS X 10.5.6 with VMware Fusion 2.0.1 (128865) running on the latest MacBook Pro. I am running Windows XP SP3 on the virtual machine. VMware Tools is installed and everything is working fine, except the DVD on the Mac is not recognized in the virtual machine. I am also connected to the CD in the VM (the little CD image in the lower right is enabled).

    In the Windows XP Device Manager, you see the DVD/CD-ROM category with a line showing a yellow "!" followed by "NECVMWar VMware IDE CDR00". The properties states, "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

    I have tried uninstalling the device and reinstalling. I have tried every option in Fusion settings, including automatic and specifying the physical disk. The physical disk shows as "Matshita DVD-R (UJ-868)". I have look all over the blogs and found others with similar issues, but no responses that seem to resolve the issue. My guess is that this is a driver issue on the XP side, but I can't find a VMware driver for the DVD anywhere, short of installing the VMware Tools again - which I have done. I have gone so far as extracting the VM Ware Tools ISO (windows.iso) and running the install directly in the XP system and that didn't work either.

    So, is this a known issue and is there a solution? Aside from user error, I suspect there *is* an issue here, but I can't get confirmation. Any help is appreciated.
     
  2. Tonerl Guest

    #2
    Fusion 2.x.x is fraught with problems.

    You'd probably get an (informed) answer more quickly if you posted your question on VMware's Fusion forum.
     
  3. Moonraker069 thread starter macrumors newbie

    Joined:
    Dec 28, 2008
    Location:
    Florida
    #3
    Thanks

    Thanks for the comment. I already did and am still waiting to get a response. Just trying to cast a broader net.
     
  4. Moonraker069 thread starter macrumors newbie

    Joined:
    Dec 28, 2008
    Location:
    Florida
    #4
    Problem Solved

    I have used two different VMWare virtual machine builds - one from a Lenovo and one from a Dell - and each had the same problem. This lead me to consider the common elements in both - my Mac hardware (the CD-DVD itself) and the VMware Fusion version.

    I decided to focus my research on the CD/DVD drivers itself, rather than VMWare or Mac. I was looking at the CD/DVD driver properties and noticed that they were signed by Microsoft so I realized that VMWare doesn't replace all drivers with their own. They obviously relied on generic drivers for some common accessories. I searched on Microsoft's site for driver issue and found this reference:

    http://social.technet.microsoft.com.../thread/3a3a94f0-fdfb-4aee-b7ad-92ee72df5744/

    The issue seems to be with the Matshita UJ-850S CD/DVD RW drive. Specifically, it is with a registry entry that seems to cause the "corrupted" or "invalid" driver error. I don't know why this fix works, but it does and I have not experienced any adverse affects yet.

    Here is an excerpt of the solution:

    Method 1: Remove the registry entry

    Modify the registry at your own risk. Note If you had installed multiple CD-writing software products on your computer, you need to uninstall the software products before you remove the registry keys.

    1. Click Start, and then click Run.
    2. In the Open box, type regedit, and then click OK.
    3. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/Class/{4d36e965-e325-11ce-bfc1-08002be10318}
    4. On the File menu, click Export.
    5. In the File name box, type savedkey, and then click Save.
    6. Click the REG_MULTI_SZ data type UpperFilters, and then click Delete on
    the Edit menu. When you are prompted to confirm the deletion, click Yes.

    Note If this data type is missing, go to Method 2.

    7. Click the REG_MULTI_SZ data type LowerFilters, and then click Delete on
    the Edit menu. When you are prompted to confirm the deletion, click Yes.
    8. Quit Registry Editor, and then restart the computer.

    Hope others find this solution as useful as I have.

    Moonraker out.
     

Share This Page