CD/DVD-ROM not ejecting disc

Discussion in 'iMac' started by aglinder, Dec 1, 2010.

  1. aglinder macrumors newbie

    Joined:
    Sep 7, 2010
    #1
    Hi,

    basically I was burning a disc via a Burn Folder, and at 40% got the error message: 0x8002006E. The disc ejected, but I reinserted it.
    Now it won't recognised the disc - not icon appears on the desktop - and I can't eject it either.
    I've tried a couple of 'tricks', such has rebooting and holding the mouse button/C, and using the eject function in iTunes and in Disk Utility. Nothing works.
    However, in Disk Utility the disc is recognised with the DVD-ROM.
    When I try to eject it makes the right sounds - like the disc is being prepared to be ejected, but doesn't pop out.
    The DVD-ROM has been acting up for a while but this is a first (before it just made worrying noises when reading discs).
    Am I going to have to take it in for repair/replacement? Any ideas?

    System Details:
    Model Name: iMac
    Model Identifier: iMac8,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 6 MB
    Memory: 2 GB
    Bus Speed: 1.07 GHz
    Boot ROM Version: IM81.00C1.B00
    SMC Version (system): 1.29f1
    Serial Number (system): YM831C9KZE2
    Hardware UUID: 1DFC990D-AAFD-587E-9C63-9CA4C6CE4F68

    System Version: Mac OS X 10.5.8 (9L31a)
    Kernel Version: Darwin 9.8.0
    Boot Volume: Macintosh HD
    Boot Mode: Normal
     
  2. Annalea macrumors member

    Joined:
    Nov 24, 2010
    Location:
    Inland PacNW
    #2
    I wish I had an answer for you. I can offer validation, though. I have an iMac with nearly identical specs, and as we speak, mine is trying to eject a dvd I just put in. It read just fine when I inserted it, but when I decided I was done and clicked eject, it made all the right sounds, and nothing is happening.

    I hope someone has an answer of some kind . . . although this seems to be a hardware issue, not a software one. :(

    (P.S.) The drive just began playing the disc again. I wish it wasn't something I'll never watch! lol)
     
  3. shaunmedrik macrumors newbie

    Joined:
    Dec 13, 2010
    #3
    CD/DVD-ROM not ejecting disc this problem is many user faced .One Belt is work for the open and close the disc door.So check the your cd to any hardware person.
     
  4. benhollberg macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #4
    My MacBook Pro isn't ejecting a DVD, I inserted it and it said it was blank, which it wasn't. So it asked what to do, I pressed eject because clearly something was wrong. Now it won't eject. It isn't making any noises when I press eject, and also it isn't showing in the Finder. I tried logging in and out and also restarting but it still is like this. Please help me out if you figured a solution to this. I also made a thread about mine, but no replies yet.
     
  5. benhollberg macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #5
    This worked for me.
     

Share This Page