CD is stuck....how can I fix that??

Discussion in 'Mac Basics and Help' started by twothreefoursix, Nov 5, 2008.

  1. twothreefoursix macrumors newbie

    Joined:
    Nov 5, 2008
    #1
    ummm okay so I put a CD into my mac yesterday and synced it into my itunes but now it won't come out!!! i've pressed the eject button millions of times and even tried sticking something in there to pull it out but nothing is working. and on top of that, it won't allow me to restart/shut down/put to sleep my mac either..... is there anything I can do???
     
  2. G-Com macrumors regular

    Joined:
    May 21, 2008
    Location:
    North of The 'Nati
  3. timestoby macrumors 6502

    Joined:
    Jun 10, 2007
    Location:
    north devon,uk
    #3
    spacebar? dont you mean the bar on the trackpad
     
  4. jodelli macrumors 65816

    jodelli

    Joined:
    Jan 6, 2008
    Location:
    Windsor, ON, Canada
    #4
    If you can see a tiny hole on the far right side of the tray or slot where the CD is poke a paper clip in there, slowly. That used to work as a last resort.
     
  5. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #5
    Holding down the mouse button during boot will normally force a cd out, to force it to boot - hold the power button until it turns off.
     
  6. anaisidoro macrumors newbie

    Joined:
    Sep 12, 2008
    #6
    it worked for me

    When my macbook did that I used a bussiness card and put double stick tape on one side of the card or a piece of tape doubled over and pressed down to imitate double stick tape. insert in into the disc slot and press the eject button. the disc will stick to the card and slowly pull it out. let me know if it works
     
  7. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #7
    Use Terminal and type 'sudo shutdown -r now' During boot, hold the trackpad button down.

    If it still doesn't come out, the disk may be physically stuck, but if you're under warranty, I would take it to the store and have it fixed since it's not worth physically damaging your drive doing it yourself.
     
  8. jayriley macrumors newbie

    Joined:
    Nov 18, 2008
    #8
    Hold Down Mouse Bar Worked!

    thank you thank you! The disc was stuck and nothing was working-- tried dragging to trash, F12 and attempted to pry it out with a paperclip.
    Evan called MacOutfitters in Doylestown PA, said it would cost $100 to look at ! Restarted at Andy's suggestion and held down track bar- IT WORKED!
    thank you very very much..
    JayRi
     

Share This Page