CD not mounting on desktop

Discussion in 'Mac Basics and Help' started by seitzteacher, Oct 21, 2009.

  1. seitzteacher macrumors newbie

    Joined:
    Dec 25, 2007
    #1
    I have an iMac G4. When I insert a CD it no longer shows up on the desktop. I've checked under System Preferences and chose CD/DVD. I made sure that "When you insert a blank CD" the Finder Opens and "When you insert a blank DVD the Finder Opens".

    Can anyone offer any help?
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    That preference only affects BLANK discs. I'm assuming you're inserting discs with data on them... to control that behavior, go into Finder's Preferences, and check the box in the "Show on Desktop" area next to "CDs, DVDs, and iPods".
     
  3. seitzteacher thread starter macrumors newbie

    Joined:
    Dec 25, 2007
    #3
    It won't show blank disks or disks with data.
     
  4. seitzteacher thread starter macrumors newbie

    Joined:
    Dec 25, 2007

Share This Page