CD stuck in drive

Discussion in 'iMac' started by dazzer21, Jun 29, 2011.

  1. dazzer21 macrumors 6502

    Joined:
    Oct 18, 2005
    #1
    I have a 2008 iMac 24" - there is a CD in the drive which will not eject. There is a 'graunching' noise as the CD spins down, then the eject mechanism starts to eject, gets so far (without and of the CD showing outside of the machine), fails and the CD falls back into place and re-appears on the desktop. I've tried all the various software solutions (drag icon to eject, re-start holding space etc) but it's a hardware problems. I presume it's pretty difficult to solve - what do I do?
     
  2. eggfoam macrumors member

    eggfoam

    Joined:
    Jun 21, 2011
    #3
    The slot-loading iMacs have a manual eject button that may help:
    http://support.apple.com/kb/HT3007

    Note that this is an electrical mechanism, so the computer has to be on. (I remember the old mechanical mechanisms that required a straightened paperclip and some force to eject a stuck 3.5" disk...)

    Good luck!
     
  3. Dan2142 macrumors newbie

    Joined:
    Jun 20, 2011
    #4
    CD stuck in Drive.

    I think I have a solution. What you need to do is hold the power button down for 15 seconds. Then let the computer shut down until it is making no noise at all. Next, start up the computer, as soon as you hear the chime hold your left mouse button down until the disk ejects. I hope this will help. :) DO NOT STICK ANYTHING IN THE DISK SLOT, NEVER.
     
  4. bjett92 macrumors 6502a

    Joined:
    Oct 22, 2007
    Location:
    Indy, IN
    #5
    Correct me if I'm wrong but that is from the old iMac days.
     
  5. eggfoam macrumors member

    eggfoam

    Joined:
    Jun 21, 2011
    #6
    Could be, but that article was last updated in September 2010. I haven't tried this on a recent iMac, so I don't know from personal experience.

    However, this is *not* the mechanical override that I remember from the Mac Plus days. So even if it's present in the OP's iMac, it may not do much good, as I imagine all it can do is trigger the same eject motor that's failing when activated by software. Who knows, though; maybe it does something slightly different.

    EDIT: Now that I look again at the article, that's definitely a very old iMac in the picture. Do newer iMacs not have any sort of similar button?
     

Share This Page