CD Stuck in my MB

Discussion in 'Mac Basics and Help' started by BdON003, Jan 17, 2008.

  1. BdON003 macrumors newbie

    Joined:
    Jan 12, 2008
    #1
    I have a serious problem. I tried installing windows through bootcamp last night on my MB w/ the superdrive, I got to the step where I needed to install windows. I put my win XP cd in and went through the installation. After the first part of the install, it then needed to reboot. When it did that, I got a disc error message and it would freeze. Now my windows CD is stuck in the superdrive and when I boot my only options are to not press a key and get the disc error message or press any key and boot from the CD. Is there some way to force this CD out? I have tried the eject button on the keyboard, holding X down when it boots up, holding Shift, and deleting the windows partition with no luck with any of that. There is no Apple store around me either.
     
  2. Tom B. macrumors 65816

    Tom B.

    Joined:
    Mar 22, 2006
    Location:
    London
    #2
    Turn off the MacBook, then, while you turn it on again, hold down the trackpad button. Hopefully that should work.
     
  3. BdON003 thread starter macrumors newbie

    Joined:
    Jan 12, 2008
    #3
    Thank you, it worked! I was getting a little worried
     
  4. Caris macrumors 6502a

    Caris

    Joined:
    Sep 25, 2006
    Location:
    Newcastle Upon Tyne, UK
    #4
    Yeah i had this problem a few month back, trackpad trick worked great :)
     
  5. BdON003 thread starter macrumors newbie

    Joined:
    Jan 12, 2008
  6. cmblackburn macrumors newbie

    Joined:
    Jan 18, 2008
    #6
    You can open up Terminal.app and type

    Code:
    sudo umount -f /dev/disk1s1s2
    if the disk does not eject after that on its own just hit the eject button. No rebooty!
     

Share This Page