CD Won't Eject After XP Install (Macbook Pro)

Discussion in 'Mac Pro' started by gormenghast, Apr 9, 2006.

  1. gormenghast macrumors newbie

    Jan 10, 2006
    Argh! I decided to install XP on my Macbook Pro just for the heck of it. So I upgraded the firmware, burned the drivers disc and installed XP. Everything seemed to work fine but..

    Then I tried ejecting the CD, no go. So I booted back into OS X and tried to eject the CD, nope it just makes this "bzzjjj" sound like it's trying to eject but it doesn't. I tried restarting and holding down the mouse button, same thing.

    Did XP screw up my Macbook Pro? It worked fined up until I tried installing XP.
  2. yankeefan24 macrumors 65816


    Dec 24, 2005
    I doubt XP could do any physical harm to your computer.

    Was it dented?

    this is the drivers disk right.

    try repairing permissions. i don't think it is software. but as always, i could be wrong.
  3. XP Defector macrumors 6502

    Apr 5, 2006
    Infrequently, I've seen warped compact-disks. Sometimes they really mess up CD-ROMS.
  4. BornAgainMac macrumors 603


    Feb 4, 2004
    Florida Resident
    My XP disk got stuck too but wasn't the first disk. Use your finger to push dwn on the bottom lip of the drive and the disk will pop out.
  5. Electro Funk macrumors 65816

    Electro Funk

    Dec 8, 2005
    The Opium Garden
    Reboot and hold down F12 - should eject install cd before splash boot screen...
  6. gormenghast thread starter macrumors newbie

    Jan 10, 2006
    Ok, so I carefully pushed the CD a bit with a credit card (while it was off) and then turned my Macbook back on and held the mouse button down.

    Bingo it ejected. So I put another disc in, doh! It's stuck again.

    Well at least I had the foresight to put the Mac OS X install DVD in instead of the XP CD, so less explaining to do when I bring it to the Apple Store on Monday I guess. :p

    Thanks all.
  7. ambrfack1 macrumors newbie

    Jan 15, 2008
    In general a CD or DVD can be ejected on a Mac (MacBook) using the physical eject button or from the finder without any problems, but occasionally this don’t work and the disc icon might disappear from your Desktop and you can’t get the disc out of your computer. However, there is a trick you can try to extract the stuck disc.

    * Restart your Mac
    * After you hear the startup chime, press and hold your mouse/trackpad button
    * After a minute or so and you think nothing is gonna happen the disc ejects
    * Release the button once the disc ejects

Share This Page