CD Wont Eject from PowerBook

jamieg

macrumors member
Original poster
Feb 28, 2006
33
0
It happened to me last night, but this was not the first time!


If (for whatever reason) a Disc gets stuck in the optical drive and wont eject using the eject button, is there any way of getting it out without having to restart?


Thanks, Jamie
 

PlaceofDis

macrumors Core
Jan 6, 2004
19,239
4
if OS X thinks its ejected and its stuck in there, only way is with a restart as far as i know.
 

MacBoobsPro

macrumors 603
Jan 10, 2006
5,115
6
jamieg said:
It happened to me last night, but this was not the first time!


If (for whatever reason) a Disc gets stuck in the optical drive and wont eject using the eject button, is there any way of getting it out without having to restart?


Thanks, Jamie
A pick axe and hammer will get it out without having to restart but its not advisable. I think restarting is the only way. Why is the disk getting stuck? If it has one of those sticky labels on it, it is likely too thick to fit through the slot properly. Try burning it onto a different disk (if that is the problem). :)
 

iMeowbot

macrumors G3
Aug 30, 2003
8,636
0
Mm, drutil tray eject from Terminal will try to spit it out. That won't do much if the mechanism is actually jammed, but it may work after a failed burn and things like that.

More ugly eject tricks in the MR Guides.
 

Davidsilence

macrumors member
Oct 3, 2005
34
0
Brighton UK
had a powerbook with same problem

I'm not sure if your CD tries to eject but then goes back in. If it does then my solution was to turn powerbook (with lid open) from horizontal to vertical position and hold down eject button
good luck
 

kjmont

macrumors newbie
Sep 29, 2006
1
0
A DVD is stuck in my Powerbook - HELP!!

I have tried everything at this site http://guides.macrumors.com/Force_Eject_a_Stuck_CD_or_DVD

I also tried taking apart my enitre powerbook following some manual I found online. I couldn't get the heatsink and fan assembly off to get to the opitcal drive.

What happens is when I push eject the computer attempts to eject the DVD but it doesn't work and the DVD restarts... I quit the DVD player and try again - nothing works!!

Someone please help...
 

pgn674

macrumors newbie
Aug 15, 2007
1
0
My friend tried everything at that site (she has a G5), and nothing worked. Then this worked, in her own words:
I shut off the ocm, took another CD, incerted it the lil bit it would go and pushed on the CD... turned com on, loaded it, pressed eject, and it came out.
I put it in again (stupid, I know) to see if it was the CD and not just the way I had put it in
and it got stuck, so I turned off, repeated, and I got it out again after two trieds.
then I put in a dif DVD I had here on the desk, it loaded right pu, played fine, and came out jsut fine!
so it's not something internal.
 

dlc133

macrumors newbie
Jul 3, 2008
1
0
Ejecting a Disc

I tried every trick I could find to get a stuck disc out of my 12" powerbook, including all those suggested here and more, but nothing worked. It soon became obvious that this was a mechanical problem. The drive would attempt to eject the disc (I could hear it repeatedly trying) but it simply wouldn't come out. I finally decided to remove the drive, but quickly found out just how difficult this is!

However, after removing the keyboard and the underlying aluminum plate, I decided to start the computer and try to eject while tapping on the top of the drive. To my surprise, the disc ejected immediately and very easily. I believe that pressure on the top of the drive was preventing the disc from ejecting. The casing of the superdrive is very flimsy, and any amount of pressure could easily interfere with the mechanical operation of the drive. I had recently replaced my hard drive, so perhaps when putting things back together, I tightened the screws a bit too much. Who knows, but it works fine now. I believe this may also explain why some people report having success in ejecting discs by holding the computer upside-down and tapping on the bottom of the computer. Good luck!
 

PLin

macrumors 6502
Oct 9, 2003
425
35
The only discs I've ever had a problem ejecting are ones that have a label attached to the top. The label increases the thickness of the disc enough to pose a problem for slot-loading drives.

One disc was so stubborn that the only way I finally got it out was to turn the computer so that the slot was pointing down and then shake the computer while ejecting the disc to let gravity help it come out.

After that incident, I don't let those labeled discs near my optical drive.