CD won't eject

Discussion in 'MacBook' started by hellomate, Oct 22, 2009.

  1. hellomate Guest

    Joined:
    Jul 13, 2009
    #1
    I have a MacBook with a CD in the drive that just won't eject.

    The volume won't mount, and I tried using

    drutil try eject

    but the drive just makes a short noise.

    Anything else I can try?
     
  2. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #2
    On boot up, press and hold the trackpad button.
     
  3. hellomate thread starter Guest

    Joined:
    Jul 13, 2009
    #3
    I tried that but it did the same thing. I think I will have to take it into the store soon.
     
  4. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #4
    If it partially ejected, you can try tipping the computer on it's side so the optical drive slot points down and give a couple gently shakes...the disc may just slide right out.
     
  5. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #5
    If the drive ejects discs slowly or appears to be struggling, insert and eject a single disc several times.

    If the drive does not eject discs using the F12 or eject key on the keyboard try dragging the disc icon to the trash.

    If the disc will still not eject holding down the trackpad button during startup should also eject a disc.
    Reset the Power Manager (PMU) or System Management Controller (SMC).

    ALSO-

    1. Restart the computer. If necessary, use the reset/interrupt button.
    2. Immediately after the system startup tone, press and hold the Command-Option-O-F key combination. The computer starts up to a text-only screen, indicating that you are in Open Firmware.
    3. At the prompt, type: eject cd
    4. Press Return.
    5. Type: mac-boot
    6. Press Return
     
  6. hellomate thread starter Guest

    Joined:
    Jul 13, 2009
    #6
    I tried going into open firmware earlier to do just that, but the machine simply will not go there.

    Again I restarted holding down command-option-O-F but it just keeps booting. I attributed it to the new machine.
     

Share This Page