Cellular calls bypass WiFi?

Discussion in 'Apple Watch' started by angusmcfisher, Sep 23, 2017.

  1. angusmcfisher macrumors regular

    Joined:
    Dec 18, 2009
    #1
    I have an AW S3 with Cellular, and I have been testing the Cellular, and came across a potential use case problem.

    If I’m connected to a known WiFi network, I still won’t be able to make and recieve calls as my network (EE) don’t have WiFi calling over iCloud.

    The only solution for now is to forget WiFi networks in places you will want to have cellular capabilities, for example at the gym.

    I think I’ve understood that correctly?
     
  2. BrettDS macrumors 65816

    Joined:
    Nov 14, 2012
    Location:
    Orlando
    #2
    I don’t know for sure about EE as I live in the US, but I have a hard time believing that they would force you to disconnect from WiFi like that in order to make calls. Instead what may be happening is that you’re running into the interstitial login WiFi bug. There is an issue with the LTE watch where it will still attempt to connect to known WiFi networks, even when they have interstitial login pages (these are the web pages that you are redirected to when you first connect to a public WiFi network where you can enter a name and password or agree to terms or whatever before the WiFi actually starts to work). Because the watch has no way to present these pages and let you login or agree to the terms then it just gets stuck. The watch thinks it’s on WiFi and doesn’t fire up the LTE modem, but because you can’t login the WiFi doesn’t work. If your gym network has an interstitial login page, then this is likely the problem you are facing.

    Apple has promised a fix in a future software update, but for now the workaround is to forget that network on your phone (while your watch is connected to the phone) so it is no longer a known WiFi network and then your watch will no longer attempt to connect to it.
     
  3. dave006 Contributor

    dave006

    Joined:
    Jul 3, 2008
    Location:
    Just West of East
    #3
    No you don't have to remove / forget the Wi-Fi network on your iPhone. To force a cellular call from your Watch, just enable Airplane mode on the Control panel and then making sure that you enable Cellular (LTE) by asking Siri to enable / turn on Airplane mode. The only restriction that I am aware of is that EE does not support UTMS as a fallback from LTE.

    If Wi-Fi Calling is enabled on your Watch, you can just make a call since your watch would be connected directly to a known Wi-Fi network.

    The way Wi-Fi calling works for the Watch by allowing your device that is connected to a known Wi-Fi to simply make and receive calls that are routed via your Carrier, in your case EE.

    Dave
     
  4. edhchoe macrumors 6502a

    edhchoe

    Joined:
    Oct 28, 2011
    #4
    airplane mode turns off everything. you cannot turn on LTE with airplane mode lit up.

    when i jumped to T mobile from verizon 2 years ago, wifi calling was available on T mobile but not on Verizon.
    EE may not support wifi calling.
     
  5. fischersd macrumors 601

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Vancouver, BC, Canada
    #5
    The Watch should know that the UMA/GAN (VoWIFI) context hasn't been established over the wifi network and default to using Cellular when you go to make a call.

    Edit: The logic in the watch for this is fairly significant (it should be able to pass your call over from Wifi to Cellular if your wifi signal is getting weak - again, if your carrier supports wifi calling).
     

Share This Page

4 September 23, 2017