Cellular data network not working on iphone 3gs jailbroken

Discussion in 'iPhone Tips, Help and Troubleshooting' started by moudy242, Jan 1, 2012.

  1. moudy242 macrumors newbie

    Joined:
    Jan 1, 2012
    #1
    I have an iphone 3gs and i have this problem since i was on ios 4...i jailbroke my iphone back then and everything works perfect on wifi but the cellular data network doesn't connect all apps say there's no internet connection...my iphone was locked on official carrier and its baseband is 05.13.04 which is known to be unlockable...and it unlocked fine with ultras0w and i put different sim cards which all worked fine except for cellular network...i thought it might be a software problem and when i upgraded to 5.0.1 with custom firmware ofcourse to preserve the baseband i found the same problem...i jailbroke and unlocked the new firmware just fine and everything works on wifi but not 3G....i tried the APN settings and input all settings for the carriers when i change sim card but not even the official carrier 3G works...can someone help me i'm sure this issue isn't just mine
     
  2. dcaplan macrumors newbie

    Joined:
    Mar 4, 2012
    #2
    Same Problem

    I have the same phone (jailbroken 3gs on 5.01) with the exact same problem. I've tried:
    1. Restarting the phone,
    2. resetting the phone
    3. Resetting network settings

    I can't figure out what to do from here.
    Has anyone else had this problem?
     

Share This Page