Cellular Data Network on Beta 3

Discussion in 'iPhone' started by jimlyonsie, Apr 17, 2009.

  1. jimlyonsie macrumors member

    Joined:
    Apr 1, 2009
    #1
    I am using an officially factory unlocked iphone on Vodafone in the UK. Beta 3 has been great for me so far. I just updated my Bloomberg app and restarted the Iphone as always> i am now getting cellular data errors for everything as I am not connected to a cellular data network. I went to the settings to check that they were correct.

    The page for cellular data network is blank now, and I cant enter the custom settings. So at the moment I can only get data over WIFI.

    Any suggestions of what may have caused this to happen (other than updating an app and restarting the phone). Furthermore anyone who can help me get my phone working with data using vodafone would be a star!!!
     
  2. jarjarblinks macrumors 6502

    jarjarblinks

    Joined:
    Nov 15, 2008
    #2
    Does sound like a bug, may not be peculiar to you, could be over your carrier. Disconnect your laptop from the Internet, then re-sync with iTunes. If that dsnt work, I think you should reload beta 3 again.
     
  3. jimlyonsie thread starter macrumors member

    Joined:
    Apr 1, 2009
    #3
    I'll give that a go, from what I have read I'm not alone having a blank page in my settings. I just don't understand why suddenly the phone would forget my APN settings. Do you know if I can restore back to beta 2 ?
     
  4. sallythemac Guest

    Joined:
    Jun 16, 2008
    #4
    I am using an o2-UK iPhone running 3.0 Beta 3 and also have a blank Network Data Settings page. So it's not just you.

    You could try dropping back to Beta 2, using the DFU method people are using to get back to 2.2.1. BUT to the best of my knowledge there are validity periods on the betas, and Beta 2's expires in just over a week. So you would have to choose between Beta 3 and 2.2.1 by the end of the month.
     
  5. jimlyonsie thread starter macrumors member

    Joined:
    Apr 1, 2009
    #5
    I've been having a rollercoaster couple of hours. First of all I try to put my phone into recovery mode. I then get the dreaded pink screen of death instructing me to connect the phone to itunes. When i chose to restore, it would not detect my iphone any longer. Then after about an hour of trying to get into DFU mode, but not really making any difference I realize how to restore from an IPSW by clicking 'alt' and restore at the same time. This seemed to work and restored my phone back to Beta 3.

    The first thing I obviously attempted was to access data using the cellular network, which failed - hence my phone no longer has the correct APN settings. I tried to change this in the settings on the phone, but it still has a blank screen on this option.

    I then decided I would restore from a BETA 2 IPSW file, as I know you can input your own APN settings on BETA 2, and I found it generally stable enough to use until BETA 4 comes out. However when I tried this restore it took me back to the dreaded Pink screen of death.

    I am now trying to get BETA 3 back on the phone again, and it is restoring I type. I will keep you updated.

    My question now is, is there a way I can manually change the APN settings on the phone without accessing the Cellular Data Network settings on the phone?

    Of course this could all be in vain if I get that screen of death agaiN!!


    *****UPDATE*****

    OK I can confirm that I can restore back to BETA 3 and the phone is functional as it was before my nightmares. Anyway the Cellular APN settings are still not working, so I can only use data at the moment in a WIFI area.

    I have done a bit of reading about changing your carrier IPCC file to change the APN settings, it all seems simple enough but I can't locate the IPCC file. It is supposed to be in: ~/Library/iTunes/iPhone Carrier Support folder. The problem is that I do not have this folder.

    It seems my last resort right now would have to be DFU mode back to 2.2.1 which in my opinion would not be the end of the world. I am now really worried whether it will work or not though!

    Also I notice to get back to 2.2.1 you have to Jailbreak, which I don't really want to do either. Once you have Jailbroken your phone, can you unJailbreak?

    So many questions!!

    Thanks for your help so far guys
     
  6. jimlyonsie thread starter macrumors member

    Joined:
    Apr 1, 2009
    #6
    I have got it working again on Beta 3.

    My APN settings are now fixed, and this is how I did it.

    You just need to download the iPhone configuration utility from apple, email yourself the .mobileconfig file with APN settings and open the attachment on your phone.

    Download it here from Apple

    In the utility you just need to create a new configuration profile and input your APN settings for your provider. It will save it as a .mobileconfig file ready to attach to your e-mails.

    Simple as that.
     
  7. lkal3 macrumors newbie

    Joined:
    Dec 29, 2007
    #7
    can explain more this way?

    hello can you explain more the step email yourself the .mobileconfig file with APN settings and open the attachment on your phone.

    thanks in advance


     
  8. jimlyonsie thread starter macrumors member

    Joined:
    Apr 1, 2009
    #8
    I'm not near my MacBook right now, but it's really quite easy. Download the utility from the link on my previous post. There is a tab for configuration profile. There is a + button to create the new profile. There are then a load more tabs within the new profile to add specific settings for APN WIFI etc. Enter your details, name the file and then export it.

    Attach the exported file to an emails and sendthe email to your phone. Open the attachment on the email and apply settings.

    Simple as that!
     
  9. lkal3 macrumors newbie

    Joined:
    Dec 29, 2007
    #9
    thanks

    it's save as profile in general settings and not in carrier cellurar data.it's correct this?


     
  10. jarjarblinks macrumors 6502

    jarjarblinks

    Joined:
    Nov 15, 2008
    #10
    Glad that you've sorted it out and running beta 3 again. :)

    In future if you need to locate the IPCC file you need to open terminal and edit it from there. It cannot be viewed from Finder. :)
     
  11. theschoning macrumors newbie

    Joined:
    Sep 13, 2007
    Location:
    london, uk
    #11
    iPhone Config Util

    Absolutely brilliant! I had the same problem with not being able to access the APN settings on my factory unlocked iPhone 3G with Beta 3. Now all sorted - thanx!!! ;-D

    Jonathan.


     

Share This Page