Centering 4:3 games instead of stretching them

Discussion in 'Mac and PC Games' started by cwilson71, Jul 21, 2008.

  1. cwilson71 macrumors newbie

    Joined:
    Jul 12, 2008
    #1
    I will be happy with an answer from the Mac side OR the bootcamp side as the issue is mainly with the widescreen monitor on the new iMacs. Since the native resolution is one of the widescreen formats i.e. 1920X1200 instead of 1600X1200, whenever I play a game that only supports the old 4:3 modes, the image is stretched. I know with my old dell wide screen there was a button I could push that would put the black bars up on each side of the image to keep it in the prosper aspect ratio but I don't know if that is possible on the iMac, (or iMac running as a windows box).

    Basically I want proper 4:3 video instead of stretched when I game. Possible?
     
  2. Cabbit macrumors 68020

    Cabbit

    Joined:
    Jan 30, 2006
    Location:
    Scotland
    #2
    try changing the desktop resolution to a 4:3 aspect before opening the game. however i have never had a 4:3 game stretched on my display before on windows nor mac os so it could be game specific
     
  3. cwilson71 thread starter macrumors newbie

    Joined:
    Jul 12, 2008
    #3
    That is the problem. You change it to a 4:3 aspect ratio screen size and if you don't see black bars to the left or right of the displayed screen then the image is being artificially stretched a bit to the left and right to fill out the screen. I understand most people have a hard time even noticing it but to me it is annoying to the point that I can't look at it.

    The next time you go into a restaurant or bar that has widescreen TV's take a closer look. Most of them don't have HTDV signals coming into them and instead are displaying 4:3 images and everyone looks FAAAAAAATTTT.

     
  4. savvos macrumors regular

    Joined:
    Sep 8, 2007
    #4
    Did the game ask you if you wanted to change the resolution when it started? I always click "no" when I see that because I don't like the imaged stretched. If that dialogue box didn't come up when you started the game, go to the in-game preferences and see if you can set the resolution from there.
     
  5. cwilson71 thread starter macrumors newbie

    Joined:
    Jul 12, 2008
    #5
    For the game in question, no "Wide Screen" resolutions were available. There is no choice but to play them stretched until... See my next post in thread!
     
  6. cwilson71 thread starter macrumors newbie

    Joined:
    Jul 12, 2008
    #6
    Solution found for Bootcamp / XP side:

    Go to ATI http://ati.amd.com/support/drivers/mac/bootcamp-xp.html and download their graphics driver and catalyst control center. After rebooting there is an option to "Keep Aspect" ratio somewhere in there. This puts the "bars" up instead of stretching the screen.

    FYI, this means you are overwriting the apple supplied driver but since you are essentially on a PC in bootcamp it shouldn't matter. From a PC user's perspective I was used to replacing manufacturer (Dell Etc.) drivers with graphics card manufacturer drivers so this was a no brainer.

    Still no idea if this is possible on the Mac side.
     

Share This Page