Certain Wifi Not Working on Yosemite Public Beta

Discussion in 'OS X Yosemite (10.10)' started by Shahab21, Sep 9, 2014.

  1. Shahab21 macrumors newbie

    Joined:
    Sep 9, 2014
    #1
    Hi,
    I have Macbook Pro Retina 2012, I updated my beta to public beta 2 as soon as it came out. 4 days ago I turned on my laptop and realized my wifi does not work with my home network anymore.
    Note:
    - My WIFI works perfectly fine with other devices
    - My iPhone's Hotspot is working on my Macbook but when I turn on my hotspot and connect my mac to it, it takes around 3-4 minutes till the internet starts running (But it never starts working with my home wifi anymore)
    - I'm using Airport Express
    - My Hotspot working fine with other devices
    - The wifi sign shows it is connected all along, but it just doesn't load any webpage or connection-based app

    How it started:
    I turned on my mac 5 days ago, it showed it is connected to my wifi but there was no page loading for 4-5minutes. Then it started working (just exactly like how my hotspot works now) but the next day it didn't work at all.

    PS: I have been reading and solving my problems from MacRumors forums all these years but this is the first time that I came across a problem that can't find a solution for it therefore I joined here :p
     
  2. stressymum macrumors newbie

    Joined:
    Feb 22, 2010
    Location:
    Buckinghamshire
    #2
    Wifi drops

    Me too! It would hang for 3-4 minutes to the point where nothing is loading and I have to quit Safari and re-start. At other times, it has been lightning fast so I can't figure it out either. I have sent feedback on the Feedback Assistant app so hopefully it gets sorted before the final release.
     
  3. dwfaust macrumors 68040

    dwfaust

    Joined:
    Jul 3, 2011
    Location:
    I am here => [•]
    #3
    I’m experiencing several issues with wifi on DP7. I cannot connect to one specific wifi network (my daughter's which runs on a 5th gen Apple Airport Extreme).

    At home, with the newest get Time Capsule, my wifi will suddenly drop out. I get an error saying that I am not connected to the internet. The only resolution is to turn off wifi, wait about 45-60 seconds and then turn wifi back on. At that point it fires right up, and all is good until the cycle repeats (after 5 minutes to several hours).

    Both situations only seem to apply to my rMBP running DP7, and both issues have been reported to Apple.
     
  4. mrjohnsly macrumors newbie

    Joined:
    Jul 16, 2010
    #4
    I had the exact same problem. It happened with both of the Public Betas, I finally found a solution by adding Google's Public DNS settings in Network Preferences. Don't know why that worked but I've not had any problems since.
     
  5. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #5
    When you say the Wifi is not working, are you sure that Wifi is not working, or could be be that Safari is hung? My safari hangs sometimes, but any other web based apps continue to download/upload normally.
     
  6. stressymum macrumors newbie

    Joined:
    Feb 22, 2010
    Location:
    Buckinghamshire
    #6
    Changed DNS preferences

    @mrjohnsly, I've just tried your solution and everything seems to load quicker initially but is now stalling slightly. But still, it is better than before. I shall persevere. Perhaps my 2010 duo-core MBP is not coping even though I have 8GB RAM.

    Thanks!
     

Share This Page