Certaines files on external HDD don't appear on Mac Pro

Discussion in 'Mac Pro' started by Jardins de Vin, Jan 2, 2015.

  1. Jardins de Vin macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #1
    I recently copied all content from an old eMac to an external Western Digital drive. I used a FireWire 400 > 800 cable for that, as the eMac is pretty old already.
    I didn't copy stuff using Disk Utility because it would sometimes give me an error and stop copying stuff, so I didn't know what was copied and what wasn't.

    Instead I slowly copied everything from "Macintosh HD" by "hand". It's weird because a lot of files still couldn't be copied, so I had to grab less files at once and copy them individually, then it worked.

    What I've noticed now for the second time - because yes I've restarted at some point because of the following issue - is that the User folder doesn't appear when I browse through the external drive on my Mac Pro. It's there because I see the size of the partition, but I just don't see it. I tried to show all hidden files, but it doesn't help. The only thing that works is if I rename the folder to some random stuff, on the eMac. Then it will show up on the Mac Pro too.

    What's happening here? I'm scared it will be the case with other files too and that I can't find them later anymore if I haven't renamed them!
     
  2. theitsage macrumors 6502a

    Joined:
    Aug 28, 2005
    #2
    My guess would be permission issue when you deal with a user folder and its content.

    Have you tried booting the eMac in Target mode then use that FW400 <--> FW800 and transfer the same files over to your Mac Pro?
     
  3. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #3
    Yeah there seemed to be quite some permission issues but I had them fixed and it still didn't work. Or did you mean that I should copy its content to a new folder with new permissions?

    Is there a way to select a folder or volume and change all the permissions of all the files inside?

    And I tried the target mode thing but it didn't work. I had tried it twice. The FireWire icon was there, moving around on the eMac, but the eMac itself never appeared on the MP. Perhaps the eMac is too old…?
     
  4. Loa macrumors 65816

    Loa

    Joined:
    May 5, 2003
    Location:
    Québec
    #4
    Hello,

    Most of "your" files (meaning non-system files) should copy without a hitch, regardless of permissions. As for system files, it's not a good idea to copy them anyway, because booting a computer using the OS from a different machine is asking for trouble.

    Anyway, no mac is too old as long as you can connect to it. I'd advise using an app like Carbon Copy Cloner or SuperDuper to copy your stuff from the eMac to the external drive (if you can find versions that will work on your eMac. What's the OS on that beast?). And install the same app on the newer mac to copy them back.

    Alternatively, you could try enabling and booting into root user on the eMac and simply copying your files to the external drives. That should take care of the permissions. Do a search for instruction on how to enable the root user, as it is different for each OS.

    Loa
     
  5. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #5
    Well, I don't know why, but some of the files won't copy the first time. Then I do it another time, and it works. It usually happens when one of them can't be copied for whatever reason. It "interrupts" the whole process of copying the rest of the files. But it's okay, I compared the size of the original Macintosh HD of my eMac and the backup, and it's more or less the same.

    Also, I won't be loading this as a backup into a newer OS. I'm just copying everything, regardless of what it is. I like to have it by side somewhere. Later I can always check and delete stuff if I want. I want to sell that eMac so I had to clean it :)
     

Share This Page