Certificate problems iPhone/iPad and MacOS too

Discussion in 'iOS 10' started by jshardlo, Jun 24, 2017.

  1. jshardlo macrumors newbie

    jshardlo

    Joined:
    Jun 24, 2017
    Location:
    Kuala Lumpur
    #1
    Hello - I've been having a problem with outgoing mail for a couple of days - it started with my iPhone when I needed to reset network settings (because my Personal Hotspot was not working). After that is started complaining that it "Cannot Verify Server Identity" when it tries to send outgoing mail.

    Now the email server I use is my own so I was able to check and the certificate it was using had expired so I thought this was the problem but when I generated new certificates for the server the problem persisted for a while but by deleting the account and re-creating it I was able to then "Trust" the new certificate. So now my iPhone is OK again but my iPad and Mac are having problems with the new certificate.

    I cannot seem to get either iPad or Mac to let me trust the new certificate.

    Apple has done a great job of making this hard to figure out.

    Has anyone any pro-tips on certificate trust stores on either Mac or iPad please?

    Versions are MacOS 10.12.5 and iPad is IOS 10.3.2
     
  2. 4268256 Suspended

    4268256

    Joined:
    Jun 23, 2017
    #2
    You may want to check if the time is the same on all your devices, as well as your server. You can also try using the Keychain Access app on your Mac to check/remove the old certificate.
     
  3. jshardlo thread starter macrumors newbie

    jshardlo

    Joined:
    Jun 24, 2017
    Location:
    Kuala Lumpur
    #3
    Thanks, I tried adding and trusting the new cert on the Mac and it has helped but now a different problem arises. The latest Mac OS seems to really limit the control you have over Mail settings. For example I cannot force it to use port 587 for sending mail. Considering switching email client to Thunderbird.
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    Yes, you can change port settings. Look in the account section of Mail preferences, and you'll see a button labeled "Advanced IMAP Settings." If you uncheck the box labeled "Automatically manage connection settings" and then click the Advanced IMAP Settings button, you can change the port.
     
  5. jshardlo thread starter macrumors newbie

    jshardlo

    Joined:
    Jun 24, 2017
    Location:
    Kuala Lumpur
    #5
    Hi chrfr, my server is using POP3 at the moment but I could look at switching to IMAP. Thanks.
     
  6. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #6
    IMAP has nothing to do with sending mail. If you want to change the port used for sending mail, see the section *under* the IMAP one, labeled "Outgoing Mail Server (SMTP).

    A.
     

Share This Page