cgpdftops is maxing out processor

Discussion in 'macOS' started by nitz, Oct 6, 2005.

  1. nitz macrumors member


    Jan 23, 2003

    I noticed that our email server (eMac, 700MHz, 640MB, running 10.2.8) was running really slow so I checked in Activity Viewer to see what processes were taking up CPU resources. I found a process called cgpdftops that was sitting at around 90-95%. I think I can safely assume that this is what was causing the problem. I tried to force quit it but it wouldn't let me because it is a daemon. I then went into Terminal and did a kill -9. That worked but it started right up again with a different Process ID. I repaired permissions but it didn't help.

    According to the Internets cgpdftops has something to do with the MacOS PDF creator. Its Parent process according to Activity viewer is CUPS. I haven't installed or changed any print/pdf/acrobat settings lately.

    Whenever I restart the computer or login the process starts right back up and the computer runs really slow. Is there someway via Terminal that I can tell the system not to start this at startup?

    Any clue as to what could be causing this? Thanks a bunch for any ideas.
    At the end is what I found in /var/log/cups/error_log


    I [05/Oct/2005:09:05:22 +0200] Listening to 7f000001:631
    I [05/Oct/2005:09:05:22 +0200] Configured for up to 100 clients.
    I [05/Oct/2005:09:05:22 +0200] Allowing up to 100 client connections per host.
    E [05/Oct/2005:09:05:22 +0200] Filter "pdftops" cannot be found!
    I [05/Oct/2005:09:05:23 +0200] LoadPPDs: Read "/private/etc/cups/ppds.dat", 12 PPDs...
    I [05/Oct/2005:09:05:24 +0200] LoadPPDs: No new or changed PPDs...
    I [05/Oct/2005:09:05:28 +0200] Started filter /usr/libexec/cups/filter/cgpdftops (PID 468) for job 32.
    I [05/Oct/2005:09:05:28 +0200] Started filter /usr/libexec/cups/filter/pstops (PID 469) for job 32.
    I [05/Oct/2005:09:05:28 +0200] Started backend /usr/libexec/cups/backend/mdns (PID 470) for job 32.
    E [05/Oct/2005:09:19:40 +0200] Scheduler shutting down due to SIGTERM.
    I [05/Oct/2005:09:19:49 +0200] Started filter /usr/libexec/cups/filter/cgpdftops (PID 535) for job 33.
    I [05/Oct/2005:09:19:49 +0200] Started filter /usr/libexec/cups/filter/pstops (PID 536) for job 33.
    I [05/Oct/2005:09:19:49 +0200] Started backend /usr/libexec/cups/backend/mdns (PID 537) for job 33.
    I [05/Oct/2005:09:19:49 +0200] Started filter /usr/libexec/cups/filter/cgpdftops (PID 538) for job 32.
    I [05/Oct/2005:09:19:49 +0200] Started filter /usr/libexec/cups/filter/pstops (PID 539) for job 32.
    I [05/Oct/2005:09:19:49 +0200] Started backend /usr/libexec/cups/backend/mdns (PID 540) for job 32.
  2. varmit macrumors 68000


    Aug 5, 2003
    Do you have it setup as a print server too, or sharing a printer from it?

Share This Page