Chance OS 4.0 won't support first generation iPhone?

Discussion in 'iPhone' started by iDAG, Apr 7, 2010.

  1. iDAG macrumors 65816

    iDAG

    Joined:
    Sep 9, 2007
    Location:
    Athens, Ohio
    #1
    I think it's a real possibility that the first generation iPhone (and iPod touch) won't support OS 4.0. My iPod touch runs so slow these days since upgrading to 3.x. If there is multitasking support I don't see how these devices can run effectively.

    Thoughts?
     
  2. -Ryan- macrumors 68000

    Joined:
    Jan 28, 2009
    #2
    I think the likelihood that the original iPhone will continue to be supported is extremely slim. It is an old device; it was introduced well over 3 years ago now, and is just extremely slow by todays standards. That said, the 3G is slow today as well, but continued development is necessary as many are still in a contract for the 3G. So no, I don't think we'll see 4.0 for 1st gen. devices. 5.0 will probably drop support for the 3G too.
     
  3. profets macrumors 68040

    Joined:
    Mar 18, 2009
    #3
    I think that its either going to support all iPhones, or only the 3GS and newer. The first iPhone and iPhone 3G are mostly the same hardware, so if the original iPhone cant support it, i don't think the 3G will.

    Or maybe just the original iPhone will be excluded because of some weird accounting issue, who knows...
     

Share This Page