Change all permissions at once

Discussion in 'macOS' started by San978, Aug 25, 2008.

  1. San978 macrumors newbie

    Joined:
    Aug 25, 2008
    #1
    On our server we have thousands of files on the system that we would like to have the permissions changed to read and write for all employees in the office when they try to access the files. For some reason, some of our permission settings have changed and everyone is constantly running into a permissions error.

    We have way to many files for us to change them one by one, is there anyway to do all the files at one time? Or at least a large amount of files at one time?

    I have tried repairing the permissions, and have also tried getting info and selecting the 'Apply to enclosed items button". This did not change all files. Is there any other way or another software that can help in doing this? Thanks!
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    You're probably not gonna like this, but there is an approach in terminal that can work...

    Code:
    cd /volumes/area       
    chmod -R 777 * 
    (area = topmost folder where you are having the problem)
    (777 gives EVERYONE read/write/execute permissions. -R means operate on everything below the topmost folder, * operates on every file)
     
  3. San978 thread starter macrumors newbie

    Joined:
    Aug 25, 2008
  4. Lesser Evets macrumors 68040

    Lesser Evets

    Joined:
    Jan 7, 2006
    #4
    I tried the terminal command and it worked, in that it tried to change permissions, but they all failed as 'not permitted'.

    My problem is that I switched hard drives a couple days back and now one drive makes me manually switch all permissions. Is there a way to circumnavigate the permission to change all permissions?
    ----------
    EDIT:

    NEVERMIND, there is a way to open ALL permissions inside a volume of any size. If anyone is interested, here's how-

    • Get info of the volume
    • Set permissions for the volume (read & write, or whatever)
    • Hit the gear symbol next to the + and - area of permissions in the info box
    • Click on the pulldown 'apply top contents of volume'

    Done.
     
  5. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #5
    Well, the reason the code didn't work is because he omitted something important:

    sudo chmod -R 777 *

    The sudo command gives you permission temporarily where you normally wouldn't.

    Glad your solution worked, but just to pass on a warning to you and anyone who might see this, it's great for an external non-bootable disk, but never try this with a disk that has OS X installed on it, you could seriously screw up the system.

    jW
     
  6. savmac macrumors newbie

    Joined:
    Oct 27, 2011
    #6
    I should have read ahead.

    I recently got a new mac at work and I transferred all of the files from my old one. I got permission errors on everything that was transferred. I stupidly took the last guys advice and now I have countless "system extension cannot be used" errors. How can I fix this?
     

Share This Page