Change default permissions when writing to HD?

Discussion in 'Mac Basics and Help' started by 390521, Dec 14, 2009.

  1. 390521, Dec 14, 2009
    Last edited: Mar 15, 2011

    390521 macrumors newbie

    Joined:
    Dec 14, 2009
    #1
    Hey there :) I'm running Mac OS X 10.5.8 and I'm having problems with file permissions. When I save a file, the file is readable and writable by the owner, and read only to all others (which I know is normal), but I would like my files to have read and write access to all upon saving them. Is there any way to accomplish this without simply changing the permissions of all the parent directories?

    Thank you :)

    P.S. if it helps to know, I'm trying to have this done to files saved in the \library\webserver\documents folder, as users accessing files through the FTP are unable to edit files if I don't change the permissions on each and every one manually
     
  2. quantum003, Dec 15, 2009
    Last edited by a moderator: Jul 1, 2015

    quantum003 macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #2
    Have you considered putting them in your "Drop Box" and changing the permissions for just that file to Read/Write for everyone else?
     
  3. 390521 thread starter macrumors newbie

    Joined:
    Dec 14, 2009
    #3
    I'm not looking to just change the file permissions. The whole problem is I don't want to have to make a file readable and writable by everyone every time I save a file. I'm hoping there's a way to change the default permissions upon saving a file to a directory.
     
  4. Mumford macrumors regular

    Joined:
    Oct 8, 2006
    Location:
    Altadena, CA
    #4
    You want to change your umask from 0022 to 0000. I did some quick Googling and found Leopard instructions, but they don't seem to work for Snow Leopard. Some other instructions I found did:

    Edit (or create if it's not there) the file /etc/launchd-user.conf to add the line umask 0000, then reboot.
     
  5. Mumford macrumors regular

    Joined:
    Oct 8, 2006
    Location:
    Altadena, CA
    #5
    Hate to bump my own reply here, but I found an easier way to do this. Grab the Secrets preference pane, the option to change default umask is under System.
     

    Attached Files:

Share This Page