change device permissions?

Discussion in 'Mac Basics and Help' started by nicoleasks, Sep 30, 2011.

  1. nicoleasks, Sep 30, 2011
    Last edited: Sep 30, 2011

    nicoleasks macrumors newbie

    Joined:
    Sep 30, 2011
    #1
    Hi, I'm new to macs and I can't find a solution to my problem anywhere -- I'd appreciate some help!

    I have an external hard drive that up to now I've only used on windows (xp and vista). When I connected it to my mac (macbook pro with lion), I found it's automatically set to read-only. I want to change a folder name and can't do it! How do I fix this?

    I'm fairly comfortable with command line so I tried following someone's suggestion to use Terminal. I used the sudo mv command, and was prompted for a password. I tried to type in the password I established in the Setup Assistant process but it didn't work: I mean, it didn't even let me type it in -- I typed but nothing appeared on the screen (no letters, no asterisks, nothing). I thought maybe it was just being super secure so after typing the password I pressed Return but all that happened was I received my command repeated back at me with the message "Read-only file system."

    This hard drive isn't password protected or read-only on my other computer (windows), so I don't think it's the hard drive's fault -- I think it's the mac.

    Any suggestions? (Please make your answer as spelled-out as possible -- I am a beginner and I don't mind if you underestimate me!!)
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    Most likely, the drive is formatted NTFS, which Mac OS X doesn't have native support for (not active anyways). Easiest solution is to download and install NTFS-3G. That will enable writing to NTFS drives (including changing the name of that folder).

    jW
     
  3. nicoleasks thread starter macrumors newbie

    Joined:
    Sep 30, 2011
    #3
    Yep, that's exactly it - thanks for helping me! :)
     

Share This Page