Change file permission

Discussion in 'MacBook Pro' started by Abu Rayane, Feb 1, 2015.

  1. Abu Rayane macrumors member

    Joined:
    Sep 23, 2014
    #1
    Hello everybody,

    I would like to change the file permission, some files cannot be copied from my external HD to my mac:

    [​IMG]

    [​IMG]

    Thanks in advance
     
  2. leman macrumors 604

    Joined:
    Oct 14, 2008
    #2
    Check the disk via Disk Utility, try copying the file from the terminal. It is possible that your external drive is corrupted.
     
  3. Abu Rayane, Feb 1, 2015
    Last edited: Feb 1, 2015

    Abu Rayane thread starter macrumors member

    Joined:
    Sep 23, 2014
    #3
    They are only some files, NOT all of them, say 5 of 3000 files are not copied

    [​IMG]
     
  4. leman macrumors 604

    Joined:
    Oct 14, 2008
    #4
    Well, it appears broken ;) I'd recommend you to copy as much data as you can from that drive to a safe location — it is likely that you will start losing more data soon. It is possible that the drive can be reused after a reformat, however, I would treat it as defective. I hope you have a second backup for your data. If not and you really need to recover it, your best bet is to get some professional help (that costs a lot of money).
     
  5. BoneDaddy Suspended

    BoneDaddy

    Joined:
    Jan 8, 2015
    Location:
    Texas
    #5
    Permission reset app may help. I had a similar issue and it corrected it.
     
  6. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #6
    The OP is messing with TimeMachine backup volume. These files are protected by special ACL: nouchg (= No User Changeable) flag is set, AFAIK.
     
  7. kendall69 macrumors regular

    Joined:
    Sep 1, 2011
    #7
    Select the File ( RIGHT CLICK ) , Folder or hard drive and GET INFO.
    UNLOCK ( that little lock lower right corner) Type in your password
    Change permission to YOU, or administrator, or whatever permission works for you.
    Then select the (gear) next to the plus minus sign. then select APPLY TO ENCLOSED ITEMS -this will change ALL PERMISSIONS in that file/hard drive etc.
     
  8. BoneDaddy Suspended

    BoneDaddy

    Joined:
    Jan 8, 2015
    Location:
    Texas
    #8
    OH! I didn't notice that at first. Well now I can help the OP a little better.

    Best piece of advice; Disregard the idiot (me). If you need help with anything else that requires minimum critical thinking, or things a 4 year old can answer, I'm your guy!
     
  9. Abu Rayane thread starter macrumors member

    Joined:
    Sep 23, 2014
    #9
    If you see on the above picture, the lock is unlocked, but the "name" list is still on gray color, cannot be changed
     

Share This Page