change iPhoto preferences without opening the application.

Discussion in 'Mac Basics and Help' started by Blowie.P, Jun 2, 2012.

  1. Blowie.P macrumors newbie

    Joined:
    Jun 2, 2012
    #1
    Hello,
    IPhoto would not import a group of photos I took on an iPhone in another country and I finally figured out it was a problem with iPhoto's places feature. So I turned off 'automatically find places' in iPhoto preferences, imported the pics and (possibly foolishly) turned back on 'automatically find places' preference. Now when I open the app it goes nuts, and i just get the spinning beachball immediately, so I can't change the preferences.
    Any ideas?
    Cheers!
     
  2. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #2
    The preferences file is in Home Folder>Library>Prefences>.....iPhoto.plist.
    It should open with TextEdit, but whether you can make sense of what is displayed is another matter. :confused:
     
  3. Blowie.P thread starter macrumors newbie

    Joined:
    Jun 2, 2012
    #3
    Thanks Dave, but I wouldn't want to mess with anything I didn't know about. Anyone?
     
  4. Blowie.P thread starter macrumors newbie

    Joined:
    Jun 2, 2012
  5. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #5
    Try trashing the Preference file. iPhoto will just make a new one when it launches.
     
  6. Blowie.P thread starter macrumors newbie

    Joined:
    Jun 2, 2012
    #6
    Thanks again Dave. So I had a look but for some reason my preferences weren't there. I located them somewhere else but there's no iphoto.pilst file in there. Any ideas? really appreciate it.
     
  7. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #7
    Upto and including Snow Leopard, preference files are found here:Home Folder>Library>Prefences>
    and you are looking for the file com.apple.iPhoto.plist

    The Home Library is hidden in Lion. I don't have Lion, but I believe that in Finder, select GO and hold the option key. Select Library in the submenu. Then navigate to the preference folder.
     

Share This Page