Change permissions on external Firewire drive?

Discussion in 'macOS' started by typecase, Jan 31, 2006.

  1. typecase macrumors 6502


    Feb 2, 2005

    I have a few directories on my external firewire drive that I get an "permissions" error whenever I copy a file to. For example, when I copy a file from my mac to one of these directories on the firewire drive, it pops up a dialog and tells me the following:

    The item [filename] could not be moved because [directoryname] could not be modified. ​

    Then it gives me the option to authenticate. Once I do, the file copies fine but when I try to copy another file it happens again. Is this a permissions problem?

    How can I repair permissions on an external firewire drive. I thought diskutility can only repair permissions on a boot volume, which my drive is not.

    Any help greatly appreciated. I've done a search but found no satisfactory solution.
  2. frankblundt macrumors 65816


    Sep 19, 2005
    South of the border
    you could try just Get Info on the drive, changing the ownership & permissions > Details > owner to you, then Apply to enclosed items, but i've often found this to be a hit and miss. There are definately chmod options in Terminal you can use which are more effective and give you more control but its too hot here to remember what they are...
    or you could use a utility like FileXaminer which will do it.

    It's not a matter of repairing the permissions, because they're not broken, they're just set to an admin level and you need to change them down.
  3. typecase thread starter macrumors 6502


    Feb 2, 2005
    Thanks Frank. I tried FileXaminer and that seems to have solved the problem. I'm hoping one day I'll be able to learn the terminal commands necessary to do what this cool utility did. :p Thanks so much for your expertise!

Share This Page