Changed HD Permissions - Work mac - Big Trouble

Discussion in 'Mac Basics and Help' started by Heisler98, Jul 20, 2011.

  1. Heisler98, Jul 20, 2011
    Last edited: Jul 20, 2011

    Heisler98 macrumors member

    Joined:
    Oct 30, 2010
    #1
    I have a MacBook Pro middle-2010 model with a 240Gig HD. I changed permissions on the HD b/c I needed an administrator account full access to several others and thought that it would be easier to just change the permissions on the entire drive. I allowed me and several other administrative accounts full access to the entire drive and said 'Apply to enclosed items'

    Now I know what that does. I'm stuck at the loading screen, and I've tried both Verbose and Single-User, even Safe boot.

    Verbose comes up with:
    launchctl: Dubious ownership on file (skipping): /Library/LaunchDaemons
    launchctl: Dubious ownership on file (skipping): /System/Library/LaunchDaemons
    launchctl: Dubious ownership on file (skipping): /etc/mach_init.d

    I've tried 'diskutil repairPermissions /' and some other chmod commands. Nothing has worked. (diskutil b/c I'm in single-user mode) I don't have access to the OS disks RIGHT NOW, and I'm going on vacation and I need it working by tonight. Any help would be greatly appreciated.

    If it helps, I do have access to the root account, and I am an administrator (you should've probably inferred that by now)


    Could you also tell me if you think the OS disks would help? I imagine that the DiskUtility framework wouldn't be accessible b/c it's in single-user mode when you boot to repair...am I wrong? Don't know. Thx.


    Thanks
    Hunter

    EDIT: Okay, JUST SAW the 'Mac won't boot' wiki post. Sorry to all who I aggravated.
     
  2. baekalfen macrumors newbie

    Joined:
    Aug 10, 2010
    #2
    I'm having the exact same issue. What wiki are you refering to?
     
  3. sliceoftoast macrumors 6502

    sliceoftoast

    Joined:
    Mar 3, 2012
    Location:
    In a Toaster
    #3
    Can you boot of your installation media or use the recovery partition by pressing Command + R

    Verify the disk permissions there using Disk Utility
     

Share This Page